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Getting Started 
 
If you wish, you can follow this introductory section using the files located on the Training CD.  You can 
open them directly off the CD but it is better if you copy the Training folder to the ModFit LT folder on 
your hard disk.  If you prefer not to load the files or do not have the CD, you can refer to the 
accompanying graphics.  We also provide a set of accompanying video AVI files that can be viewed in 
lieu of this written tutorial. 
 
 In this first tutorial, we will frequently refer to two basic ModFit LT operations, “Open File” and “Auto 
Analysis”.   
 
To open a file: 
 

�� Click on the File toolbar button. 

�� Navigate to your main hard disk and locate the folder of interest.   

�� Click on this folder and a list of files should be displayed on the left side of the dialog box.  

�� If the files do not appear, check the file filter and change it to “all files”.  

�� Select the file you want to open and click on the Open button. 

All of the files we will need for part A are located in the Generated Data Files folder.  The chart below 
shows the location of this folder. 
  

 Hard Disk (Top) 
  ModFit LT 
   Training 
    Configuration Files 
    Data 
     Aneuploid Files 
      Reports 
     Diploid Files 
      Reports 
     Multiploid-Hypodiploid Files 
      Reports 
     Other Files 
      Generated Data Files 
      WithStds 
     Proficiency Test Files 
      ExamAnalysis 
      ReferenceReports 
      Reports 
     Tetraploid Files 
      Reports 
    Handouts 
 

 
To perform an Auto Analysis, click on the Auto toolbar button.  No other action is required. 
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Part A – What is a DNA Histogram? – Prerequisite tutorial 

 
  

 
  
 
This diagram (see Figure 1) represents the eukaryotic cell cycle, highlighting the major cycle divisions.  A 
resting cell in G0 (“gap zero”) has the normal DNA content of chromosomes, called 2C because it has 2 
complements of DNA.  Sometimes induced by cytokines, cells will enter G1 and after some time interval 
will start to duplicate their DNA content.  As soon as DNA replication begins, the cells enter into the 
synthesis phase, or S-phase.  Cells in S-phase increase their DNA content as they progress through this 
stage.  At the end of S-phase, cells enter G2 and later enter the stage of mitotic division, M, which 
produces two identical daughter cells, each with 2C DNA content.   
 
Why do we measure total nuclear DNA?  The use of DNA dyes such as propidium iodide (PI) provides a 
relatively easy means to determine how many cells are in each major stage of the cell cycle.  In general, 
increased S-phase suggests an active cycling population.  Note that this is not measuring individual 
chromosomes, but total DNA content only. 
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 Study guide questions: 
 - What is meant by 2C? 
 - How does the DNA content of cells in S-phase compare with cells in G0G1 and cell in G2M?
 - Can we measure individual chromosomes? 
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If we could make ideal measurements of the DNA content of cells in various stages of the cell cycle, we 
would see something like the upper panel in Figure 2. The number of observations is represented on the 
y-axis, and DNA content by the x-axis.  We call such a distribution an ideal one-parameter DNA 
histogram, and it serves as a basis for our modeling analysis. 
 
In practice, however, the measurements have some intrinsic error in them, influenced by biological 
factors such as sample source; electronic factors such as light source, detector and amplifier noise; and 
physical factors such as instrument alignment and optical filters.  These factors broaden each point in the 
ideal histogram, as shown in the lower panel to form the DNA histogram we typically observe. 
 
 
 
 

IDEAL

OBSERVED

Figure 2 

Study guide questions: 
 - What is the expected relationship of the G2M and G0G1 peak positions? 
 - Why is a G0G1 peak shaped the way it is? 
 - What type of model component is typically used to model S-phase? 
 - What is the expected range of the debris distribution? 
 - Where would you expect to find aggregates? 
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Now let’s look at a representative 
simple DNA diploid histogram (di, or 
two-ploid).    
 
We should note that the prefix “DNA” 
is used with diploid and as we’ll see 
later, aneuploid, to distinguish the 
cytometric definition from its 
cytogenetic counterpart, (Cytometry 
5, 445-446 (1984)). Instead of 
referring to a histogram as diploid we 
say DNA diploid. 
 
��In ModFit LT, open the file 
DNA00.FCS.  

  
In this simple example (see Figure 
3), only the G0G1, S-phase and 
G2M compartments are shown; 
there are no debris or aggregate 
events.  The small black triangles 
below the x-axis indicate the most 
probable peaks in the histogram.   
 
Note, these files were created with a 
program that generates artificial 
histograms.  This program allows us 
to specify percentages and location 
for each population.  We use these 
generated histograms as “truth” for 
evaluating ModFit LT’s models. 
 
Let’s do an automatic analysis; click 
on the Auto toolbar button on the 
toolbar.  In Figure 4, the G0G1 and 
G2M peaks are modeled as 
Gaussian distributions, and the S-
phase is estimated by a broadened 
rectangle.  The lower graphic is an 
expanded view of the y-axis, useful 
for visualizing small distributions like 
the S-phase and aggregates. Note 
also that the G2M peak position is 
about twice the G0G1 peak position, 
as we would expect from the cell 
cycle characteristics reviewed 
earlier.  For simple DNA histograms 
like this example, we expect the 
calculated S-phase (7.67%) to be 

very close to the actual S-phase (7.69%). 
 

 
 
 
 

 

Figure 3 

Figure 4 
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Let’s add a little complexity to the 
histogram.   
 
��Open the file DNA01.fcs 
 
Notice the debris events downscale 
of the G0G1 peak, (see Figure 5).  
 
An “event” in a listmode file contains 
a set of measurements that arises 
from a particle passing through the 
flow-cell that satisfies the acquisition 
trigger threshold setting. 
 
Although it is more obvious below 
the G0G1 peak, keep in mind that 
the debris distribution underlies the 
entire histogram.  Debris events are 
typically fragmented cells and/or 
nuclei produced during the sample 
preparation and staining, and may 
also arise from necrotic cells present 
in the original sample. 
 
 
 
 
 
 
��Click the Auto toolbar button to 
see how the debris is modeled.   
 
Even with the debris events 
underlying the G0G1, G2M and S-
phase, the calculated S-phase 
(7.17%) is very close to the actual S-
phase (7.05%). 
 
 
Note: Debris modeling works best 
when the threshold or discriminator 
is as low as possible as represented 
in this example. 
 
 
 
 
 

 
 
 
 
 
 

 
  
 
 

 

Figure 5 

Figure 6 
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Now let’s add the last component 
that we will need to consider, 
aggregates.  Note in Figure 7 the 
additional peaks upscale in the 
histogram.  These additional peaks 
represent aggregates between all 
events that make up the DNA 
histogram, the most notable being 
the doublet and triplet aggregates of 
the G0G1 peak.  The amount and 
distribution of the aggregate forms 
are dependent on the sample source 
and preparation and may be highly 
variable. Be aware that an aggregate 
can include interactions between 
nuclei or between debris and nuclei. 

 
 

 
 
 

 
 
��Click the Auto toolbar button. 
 
The aggregates are now modeled 
along with the other types of events.  
Notice in Figure 8 that the aggregate 
distribution extends under the G2M 
and G0G1 peaks and throughout the 
S-phase region.  Even with 
aggregate events in the histogram, it 
is still possible to get good 
correlation between the calculated 
S-phase (6.64%) and the actual S-
phase  (7.05%).   
 
You have seen a representation of 
the various model components in a 
typical DNA histogram: Gaussian, 
broadened rectangle, debris and 
aggregate distributions.  Now, we’re 
ready to look at even more complex 
data. 
 
 

 
 
 
 
 

 

 
 
 
 

Figure 7 

Figure 8 
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��Open the file DNA03.FCS.   
 
We have added a second cell cycle 
(see Figure 9), one that is DNA 
aneuploid.  Although it is a more 
complex distribution, similar 
modeling concepts apply.  Make 
sure you recognized the DNA diploid 
G0G1, DNA diploid G2M, DNA 
aneuploid G0G1, DNA aneuploid 
G2M, debris and aggregates.   
   
“Aneuploid” comes from: an, not 
euploid, meaning not an even 
multiple of chromosomes. 
 
The DNA index, DI, is defined as the 
position of the DNA aneuploid G0G1 
peak divided by the position of the 
DNA diploid G0G1 peak.  In this 
example the DI is 1.44. 

 
 
 
��Do an automatic analysis. 
 
��Identify the various modeling 
components, including the two S-
phase compartments (see Figure 
10). 
  
Even with the added complexity of 
the second population, the 
calculated DNA Diploid S-phase 
(6.71%) is very close to the actual 
value (6.91%).  More importantly, the 
calculated DNA Aneuploid S-phase 
(14.51%) is also very close to the 
actual value (14.92%). 
 
 
 
 

 
 

 
 
 
 
 
 
 
 

 
 

 
 

Figure 9 

Figure 10 

Study guide questions: 
- What is a DNA aneuploid population? 
- What is a DNA Index (DI)? 
- Can you model a separate DNA aneuploid S-phase? 
- How should you handle overlapping S-phase distributions? 
- What is a DNA tetraploid population? 
- Does the model chosen say anything about the biology of the sample?

DNA Diploid G2M + aggregate

DNA Aneuploid G2M + aggregate

DNA Aneuploid G0G1 
DNA Diploid G0G1

Aggregate 

Aggregate 

Debris
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��Open file DNA04.fcs, an example 
of a DNA hyperaneuploid population. 
 
Notice (see Figure 11) that the two 
S-phase components overlap.  
 
As a general rule, when two 
components of similar shape overlap 
significantly, the component of lesser 
significance should be turned off. 
(Rule: II.B.1.a.1)   
 
As a result of extensive statistical 
validation studies, Verity Software 
House has established a rule that we 
use to determine whether to try to 
model overlapping S-phase 
components.  It says, “If the DI is 
between 0.7-1.0 or 1.0-1.3 disable 
the diploid S-phase and make DNA 
diploid and DNA aneuploid G2M’s 
dependent.” (Rule: II.B.1.d.2) 
  
 
��Do an automatic analysis of this 
file.   
 
Notice (see Figure 12) that the DNA 
aneuploid DI is 1.20 and the DNA 
diploid S-phase is reported as zero.  

The S-phase is inactivated because ModFit LT’s automatic 
analysis has determined that the “1.3 DI rule” applies to this 
histogram and has disabled the DNA diploid S-phase 
accordingly.  
 
 
As a consequense of disabling the diploid S-phase, the 
aneuploid S-phase may be slightly elevated.  In this case the 
calculated DNA aneuploid S-phase (15.22%) is still quite close 
to the actual S-phase (15.00%). 
 
 
 
 
  
 
 

 
 
 
 
 
 

Figure 12 

Figure 11
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Last, we’ll introduce a special case of 
aneuploidy, that of a DNA tetraploid 
population. 
 
��Open file DNA05.fcs (see Figure 
13). 
 
A DNA tetraploid population’s G0G1 
heavily overlaps the DNA diploid 
G2M.  Another rule, as we saw 
earlier with the hyperdiploid example,  
states that overlapping components 
of similar shape should not be 
modeled. (Rule: II.B.1.a.1) Since the 
DNA aneuploid population is always 
of analytical importance, we typically 
disable the diploid G2M model 
component for DNA tetraploid 
histograms.   
 
 
 
 
 
 
 
 

��Do an automatic analysis (see Figure 14).  
 
As we discussed above, the DNA diploid G2M is disabled for 
DNA tetraploid histograms.  Note that there is good agreement 
between the calculated DNA Aneuploid S-phase (14.52%) and 
the actual (14.87%). 
 
ModFit LT has a special feature to adjust for this known source 
of error, which we will discuss in the next session. 
 
 
 
 
 

Figure 13 

Figure 14 
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In this example, the DNA aneuploid population is nearly half of the cycling populations present, so 
recognizing a DNA tetraploid histogram is not too difficult.  There are times, though, when the decision to 
use a DNA tetraploid model for a proportionally smaller aneuploid population is not as well-defined.  
Later you will see an example of this when we go through the section on DNA tetraploid data files, and 
you will use the DNA Analysis Rules to guide your decision process.  At this point, we hope you are 
familiar with typical DNA histogram patterns and how automatic analysis determines the underlying 
components. 
   
You have learned how a DNA histogram relates to the cell cycle and you have seen that there are many 
types of events in a DNA histogram.  The events in peaks such as G0G1 and G2M are modeled with 
Gaussian model components, S-phase events are modeled with a broadened rectangle, and debris and 
aggregates by their respective model components.  We need to model the histogram because many of 
these model components are heavily overlapped. 
 
You have seen that DNA histograms may contain more than one cycling population, with the second 
cycle called the DNA aneuploid population.  You have also seen a special case of DNA aneuploidy, that 
of a DNA tetraploid population, and have learned some considerations that apply to the analysis of DNA 
tetraploid histograms.  With this introduction in mind, you are now ready for some real data files and to 
look more closely at DNA analysis. 



Part A – Getting Started  ModFit LT Training 

(c) 2001 Verity Software House, Inc.  All rights reserved. A-11 Revision: 5/7/2001 

 
Study guide questions: 
 

- What is meant by 2C?  Cells that have the normal 2-complement set of chromosomes. 

- How does the DNA content of cells in S-phase compare with cells in G0G1 and cells in G2M?  
Variable between G0G1 and G2M. 

- Can we measure individual chromosomes?  No, only total DNA present in the nucleus. 

- What is the expected relationship of the G2M and G0G1 peak positions?  The G2M position is 
usually about twice that of the G0G1 position. 

- Why is a G0G1 peak shaped the way it is?  Sample preparation, instrument and biological factors 
all contribute to broadening the observed DNA content into roughly a Gaussian distribution. 

- What type of model component is typically used to model S-phase?  A single rectangle, a 
conservative approach, is usually used for typical DNA histograms. 

- What is the expected range of the debris distribution?  Debris underlies the entire DNA 
histogram.  The continuity of debris is the main reason why we do not recommend any gating strategy 
to “remove” debris. 

- Where would you expect to find aggregates?  The major aggregate forms will be found at two 
times (doublets) and three times (triplets) the G0G1 peak position, but other aggregate forms will be 
distributed throughout the histogram. 

- What is a DNA aneuploid population?  A cell cycle that is distinct from the DNA diploid population 
is called DNA aneuploid.  Populations whose G0G1 is below the DNA diploid are called DNA 
hypodiploid, and those above are called DNA hyperdiploid. 

- What is a DNA Index (DI)?  DI is the mean position of the aneuploid G0G1 peak divided by the mean 
position of the diploid G0G1 peak.    

- Can you model a separate aneuploid S-phase?  In most circumstances, yes. 

- How should you handle overlapping S-phase distributions? In general, DNA hyperdiploids with 
DI’s of 1.3 or less and DNA hypodiploids with DI’s of 0.7 or greater should have the DNA diploid S-
phase compartment turned off. 

- What is a DNA tetraploid population?  A true DNA tetraploid population is one whose G0G1 DNA 
content is 4C; its G2M will be at 8C and an S-phase between the G0G1 and G2M. 

- Does the model chosen say anything about the biology of the sample?  Not necessarily.  The 
model is chosen only to match a set of observations about the DNA histogram.  For example, a 
histogram with one cycling population usually uses a “diploid’ model, whether or not the G0G1 is truly 
a 2C DNA content.   A DNA tetraploid model may be used for a DNA aneuploid population whose 
G0G1 significantly overlaps the diploid G2M position.  
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Part B – Introduction / Training overview – 5 minutes 
 
This training is based on the DNA Histogram Analysis Rules found in Appendix 1 and has a goal of 
maximizing your interaction with the program during the training process.  The rules are largely the result 
of an extensive review of thousands of data files with known clinical outcome by investigators from the 
US and Europe.  (Bagwell CB, Baldetorp B, Clark GM, Spyratos F, et. al. Optimizing Flow Cytometeric 
DNA Ploidy and S-phase Fraction as Independent Prognostic Markers for Node-Negative Breast Cancer 
Specimens. Cytometry 2001 (June): Vol 46, #3). 
 
This rule set is designed to greatly reduce the variability of results obtained by different operators who 
may otherwise follow different paths at key analysis decision points.  Examples of such decision points 
include making a G2M dependent on G0G1 or allowing it to float; allowing a component to be modeled or 
disabled; and deciding if a given file is to use a DNA aneuploid or a DNA tetraploid model.   
 
The example files used in this training are from a reference laboratory data set.  To ensure that the 
program’s Auto Analysis functions match the training files, we will load three program configuration files 
in part E:  the Auto Analysis settings file, StdAutoSettings.aas; the peak finder settings file, 
StdPeakFinder.pf and the configuration settings file, StdConfiguration.mcf.  
 
The histogram below shows a typical modeled histogram containing two standards, a DNA diploid and 
aneuploid population.   
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Part C – ModFit LT overview – 5 minutes 

 
�� Open ModFit LT 3.0 or above on your computer. 

After the program is loaded, the Program Banner dialog box is displayed (see left figure below). The 
banner page contains phone, fax and email information for Verity Software House as well as program 
information such as the version, serial number and build date.  It also contains two buttons. The  
Registration button will take you to the Register Software dialog box (see right figure below).  The OK 
button will close the Program Banner dialog and allow you to start using the program. 

 
If the program is not registered, the Register Software dialog will be displayed when you start 
the program. See “Registering your new software” section in the ModFit LT User Guide to 
properly register the software. 

 

                 
 
 
 

�� Click the Banner dialog box’s OK button.   

The user login dialog is now displayed. It contains a User Group drop-down listbox containing the 
options, “Standard User”, “Advanced User” and “Administrator”.  Each of these user levels has different 
associated  “permissions” and controls access to certain program functions.  A more detailed description 
of these User Groups categories and their permission functions can be found in the online Help and in 
the manual.   

 
To configure ModFit LT, you must login as an “Administrator”.  If you are not an “Administrator” 
for ModFit LT, ask your administrator to perform the configuration steps in part E.  

 

 
 
 
 

�� Enter your first name, select Advanced User and type “Epsilon” for the password. 
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You will see only asterisks as you type each letter of the password. 
 
 

�� Click on the OK button. 

The user login dialog box will disappear and you will now see the default application window. 
 

�� Click on the File toolbar button.  

Files can be opened using either the File button or the File menu. Reports can only be opened from the 
File menu. 
 

�� Navigate to the “Generated Data Files” folder.   

This folder is the same one used in the first section. To show the subfolders inside a folder, double-click 
on the folder icon. This operation will expand the folders contents by one level.  You can also double-
click on the parent folder again to hide the lower levels. 

 
�� Select the data file “DNA00.FCS” from within the “Generated Data Files” folder and click on 

the Open button. 

When you click on the Open button, the program will load and display a histogram in its “report-based” 
window.  Notice that the un-modeled histogram is placed onto the report page in a default location and 
can be moved or resized as desired.  
 
Once the cell cycle analysis is performed, the program will place a default set of results on the report 
page as well.  Other graphics and result elements can be added to make this report a truly customized 
document.  As we will see in the following tutorials, the format can be saved and used as a template for 
future analysis sessions. 
 
Now that we have the program open and some data to work with, there are a couple of important 
program areas that need to be identified.  Let’s start at the top of the screen.  Here you will see a set of 
menu items (File, Edit, View, Analysis, Tools, Help).  Underneath the menus are a line of buttons 
called “toolbar” buttons.  These buttons provide a fast and easy way to access common program options.   

 
Note that the buttons are arranged from left to right in the general sequence used for a typical 
analysis.   

 

 
 
 
 

Below the buttons is the application window, containing the report page.  
 

 Note, you may move report objects off the report page by holding down on the Shift key while 
dragging the object off the page. 
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File Batch (see below) and Report Batch control bars are displayed below the application window when 
multiple files or reports are selected.  Just below the batch control bar area is the Status bar.  The 
Status bar contains information such as region position values when moving or adjusting a region; 
AutoLinearity status, name of the currently loaded file, batch item counter, flags for when AutoDebris 
and/or AutoAggregates are active, the type of S-phase shape used and the Database active status. 

 
Note, when multiple reports are selected, the Report Batch control bar will be displayed in the 
area to the right of the File Batch control area.   

 

 
 
 File Batch control bar Status bar 

Location of the Report Batch Control bar when active.
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Under the File menu, you will find the menu item, “Open...”.  When this option is selected, two additional 
sub-menu items appear,  “Report…” and “Data…”.  

 
The “Open->Report” menu is the only place you can open reports but “Open->Data”  performs the 
same function as clicking on the File toolbar button. 

 

 
 
 

The Edit menu contains a number of other useful commands such as “Database...”, “Quick Model 
Editor...”, “Full Model Editor...”, and “Options and Configuration...”.   You will have need of all these 
editing options in the later tutorials. 

 

 
 
 
 

�� Leave this data file open and let’s move on to the next tutorial section.   
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Part D – AutoAnalysis: how it works.  – 15 minutes 
 
What are the black triangles under the DNA histogram graph (see figure below)?   
 

 
 

A black triangle indicates a statistically significant peak that also satisfies a set of user-defined filters.  
The properties that control the sensitivity of finding “real” peaks are located in the PeakFinder Settings 
dialog box (Edit menu).  Automatically identifying “real” peaks is quite important for the proper 
functioning of the Auto Analysis system.   In the next tutorial, we will further examine these settings to 
better understand how they can optimize Auto Analysis for your specific type of data files. 
 

�� Click the Auto toolbar button.  

  
When you click on the Auto button, the program evaluates all the peaks found by the Peak Finder 
clustering system and then methodically determines a most probable DNA Ploidy pattern that is 
compatible with all the peaks identified.   For example, if the algorithm finds a peak at channel 50, it then 
will examine the region around channel 100 for a second peak.  If one is found, the Auto Analysis 
system further evaluates this peak to determine if it might be a G0G1 of a DNA aneuploid population or 
the G2M of the first peak.  In this manner, the program incrementally builds a mathematical model that 
should best analyze the data.  For this system to work well with your data, the Peak Finder and Auto 
Analysis settings need to be optimal for your laboratory.  Normally, the default settings will do an 
adequate job, but a little effort on your part to tailor the system will have solid long-term benefits.   
 

The Auto Analysis system can and will make mistakes and it is your responsibility to detect and 
fix these mistakes when they occur. 

 
After creating the model, the program automatically determines the range positions and estimates for 
each model component.  Starting with these initial estimates, the program then tries to minimize the 
differences between the model and the observed data by changing each model parameter according to a 
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method first published by Marquardt.  The general idea behind modeling is that when the mathematical 
model’s parameters are finally adjusted to minimize their difference to the observed data, they are 
assumed to represent the underlying biology represented by the histogram. 
 
The figure below shows the histogram after Auto Analysis.  Each model component is assigned a color, 
which aids in the understanding of the final fit.  For example, both the G1 and G2 of the DNA diploid part 
of the model are colored “red”.  The smooth bold line that appears above each of these colored model 
components is the model’s best-fit line (not well seen in this example).  It should run through the data as 
close as possible.  The analysis result that quantifies how well the model fits the data is the RCS or 
Reduced Chi-Square value.  RCS values of less than five generally represent valid fits of the data.  In 
this particular example, since the data has no statistical noise, the RCS is extremely low, 0.003.  You will 
never see a RCS this low for typical DNA histogram data.  
 

�� Familiarize yourself with the layout of the model fit and the equation results. 

We will go into a lot of detail on how to interpret this information in the later tutorials, G-K. 
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Part E – Peak Finder, Auto Analysis and Configuration Settings. 
   
The files contained in the subsequent tutorials are from a few European laboratories that have a defined 
staining and acquisition protocol.  For example, all the files have two internal standards, chicken and 
trout RBC’s.  During acquisition, the operators tried to align these standards to defined target channels.  
The preparative protocols used fresh or frozen tissue, which generally results in lower %CV’s than 
paraffin embedded samples. 
 
All these factors contribute to a particular type of DNA histogram that can be optimally analyzed by a 
specific set of Peak Finder, Auto Analysis and Configuration settings.  In this tutorial, we will make 
sure your ModFit LT program has the benefit of these settings and we’ll show you what you should do to 
optimize them for your data. 
 
Let’s load in one of these tutorial files to better examine the effects of these settings. 
 

�� Navigate to the “Diploid Files” and load “DipExample2”. 

File location: “Training \ Data\ Diploid Files” 
 
�� Choose FL2-A as the parameter to use and then click OK. 

Do not click on the Auto toolbar button! 
 

 
The first two peaks are the chicken and trout RCS’s (see figure above).  Depending on your 
current settings, the first peak may not have a black triangle associated with it.   

 
One of the reasons standards are used in a histogram is to help detect DNA hypodiploids.  A 
reference standard is needed to unambiguously determine the position of the DNA diploid 
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population, particularly when dealing with DNA hypodiploids and DNA hyperdiploids.  You will see 
examples of these special histograms later when you work with DNA aneuploid files. 

 
Loading Auto Analysis Settings 
 
We will now load in all the settings that should make the analysis of this data a lot easier. 
 

�� From the Edit menu, choose “Auto Analysis Settings...”. 

�� Scroll down to and click on the Open… button. 

�� Navigate to the “Configuration Files” folder (Training\Configuration Files\) 

�� Select the file StdAutoSettings.aas and click on the Open button.  

If you do not see the file, set the file filter to “show all files”.   
 

The two figures below show the differences between “Default” and “Training” file settings. 
 

Program Default Training File Settings 
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�� Click on the Edit… button for the Properties of standards control.   

�� Click on the “Standard1” entry. 

This dialog allows you to name the standard and to define its expected position in the histogram.  The 
Standard2 object contains similar information for the second standard in this data set.   

 
�� Click on the “Standard2” entry to see how it has been set.   

On a 256-channel histogram, the position of standard1 should be at channel 18 and the position of 
standard2 should be at channel 38.  You can calculate the ratio of the position of either standard to the 
position of the DNA Diploid G0G1 population.  This ratio can be used to help Auto Analysis determine 
the ploidy of the samples.  

 
�� Click on the OK Button to close the Edit Properties for Standards dialog box. 

�� In the Edit Properties for Auto Analysis Settings dialog box, scroll down to the Ploidy 
Determination section. 

The Ploidy Determination option is a very powerful tool that can be a used to locate DNA hypodiploid 
populations and DNA aneuploid populations showing only one cycle. 

 
Note that the ploidy determination has been set for “First Cycle is Diploid”.  This option has been 
intentionally left this way to make some points later on.  If you had standards in your samples, 
you could set this option to use one of the standards to determine the expected location of the 
Diploid G0G1.   

 
�� Click the OK button to close the Edit Properties for Auto Analysis Settings dialog.  These 

settings will be discussed later during the analysis and review of the data files.   

�� Click on the Yes button to save these settings as program defaults. 
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Loading Peak Finder Settings  
 

�� From the Edit menu, choose “Peak Finder Settings…”.  

�� Click on the Show button. 

A new window (see figure below) will display the currently loaded histogram and the current Peak Finder 
settings.   

 

 
 

�� Slowly move your mouse pointer over the histogram.   

The program will display two lines surrounding statistically significant peaks.  In the lower part of the 
window, you will see a list of the Peak Finder filters; slide bars to adjust these options, the current Peak 
Finder settings, a column that indicates whether the currently selected peak passes each criteria and the 
peak’s actual value for that criteria or filter.  

 
�� Move the slide bars to change the criteria and see the peak filtering effect.   

Don’t worry about changing these settings because you are about to reset them all in a moment. 
This technique is an easy way to find out why the program didn’t find a peak that you believe is 
there or is finding peaks that you don’t believe are peaks.   

 
�� Click on the OK button to close the Peak Finder dialog box. 

�� Scroll down to and click on the Open… button. 

�� Navigate to the Configuration Files folder (Training\Configuration Files\) 

�� Select the file StdPeakFinder.pf and click on the Open button.  

If you do not see the file, set the file filter to “show all files”.  
  
�� Click on the Show button again to see the effect of these new Peak Finder values.  
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You should now see five black triangles indicating that the program has found four peaks.   
 

 
 

Note that you can restore the default Peak Finder values at anytime by clicking the Reset button 
in this dialog. 

 
The two figures below show the difference between the default values and the values set for the training 
files.  

 
Program Default Training file settings 

 
 

 
�� Click OK to close the Edit Properties for Peak Finder Settings dialog. 

�� Click the Yes button to save these settings as program defaults. 

Options and Configuration 
 

�� From the Edit menu, choose “Options and Configuration…”.   

The Edit Properties for Options and Configuration dialog box (see figure below) contains other 
configuration items.  You are encouraged to review the manual or on-line help for a full description of 
these options. 



Part E – Peak finder, Auto Analysis and Configuration Settings ModFit LT Training 

(c) 2001 Verity Software House, Inc.  All rights reserved. E-6 Revision: 5/7/2001 

 
�� Scroll down to and click on the Open… button. 

�� Navigate to the Configuration Files folder (Training\Configuration Files\) 

�� Select the file StdConfiguration.mcf  and click on the Open button.  

�� If you do not see the file, set the file filter to “show all files”.  

You are now ready to start analyzing files.  The first part of the next section will discuss the general 
strategy you will use for each set of files.  You will then go through each data set using this strategy. 
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Part F – File Analysis and Review General Strategy  – 5 minutes 
 
The recommended file analysis strategy is a five-phase process.  
 
Phase 1 – Auto Analysis and report saving.  Load the DNA report template and analyze all files using 
automatic analysis in batch mode, automatically saving reports. 
 

 
 
 
 
 
 
 

 
 
Phase 2 – Review of Auto Analysis reports.  Load and review each stored report.  The reviewing 
process is guided by a set of DNA analysis rules (see appendix 1).  Each reviewed report is 
automatically re-saved. Of all the phases, Phase 2 requires the most attention.   

 
 
 
 
 
 
 
 

 
Phase 3 - Automatic Linearity Factor Detection.  Using Batch Report processing, run AutoLinearity on 
all reports 
 

 
 
 
 
 

 
 
 
Phase 4 - Final review.  Final review of all reports making sure AutoLinearity did not create any 
problems. 
 

 
 

21

1 2
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Phase 5.  Automatic report printing and/or database generation. 
 
 

 
 
 
 
You will use the first four phases for each set of tutorial data files.  This approach to DNA analysis is 
designed to efficiently and reproducibly analyze large numbers of histograms. 
 
Note: The files in this training set are arranged into DNA diploid, DNA tetraploid, DNA aneuploid, and 
DNA multiploid / hypodiploids for training purposes only.  This separation is neither required nor 
expected for routine analysis. 
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Part G - DNA diploid files – 40 minutes 
 
DNA diploid histograms have one cell cycle and are reasonably easy to analyze.  In the next few 
sections, we will use the four-phase approach to DNA analysis (see Part F for overview).  The DNA 
histogram examples in this section have been carefully chosen to demonstrate some important aspects 
of the analysis, setting the stage for the more complex analyses that follow.   As much as possible, we 
will introduce program features and cell cycle analysis strategies as we analyze the example files.  In 
order to streamline these training tutorials, we will try to refrain from needless repetition.  However, on a 
periodic basis, we will review the covered material.  

 
Phase 1 – Perform Auto Analysis and generate report files. 
 
We will first load our DNA report template, select the DNA diploid files, properly configure the File Batch 
control and then process all the files using Auto Analysis. 
 

�� Click on the File menu and choose Open Report....  

�� Navigate to the folder under “Data”, select the file, “DNAReportTemplate.mfl” then click on 
Open. 

Loading the DNA report template automatically configures all the report graphics.  In these 
tutorials, we will be introducing you to the benefits of X and Y zoomed graphic objects. These 
report objects are automatically loaded with the report template.  The report template is a 
convenient and efficient method for preparing the system for cell cycle analysis.  After you have 
finished these tutorials and feel comfortable with DNA analysis, you may consider further tailoring 
the report for your own laboratory needs (see Report Design in the ModFit LT User Guide). 

 
�� Click on the File button on the toolbar (first toolbar button on left). 

�� Navigate to the “Diploid Files” folder.   

Remember to click on the “Diploid Files” folder in the tree control shown on the right-side of the 
dialog.  The files contained in this folder will be displayed in the listbox on the left-side of the 
dialog.  If the file names do not appear, change the file filter to “all files”.   

 
�� Multiple-select all of the diploid example files (see figure below). 
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Selecting multiple files can be done a couple of ways.  One of the easiest is to select the first file, 
press and hold the Shift key on the keyboard, and then click on the last file.  
 
�� Click the Open button. 

�� Select “FL2-A” as the analysis parameter. 

When ModFit LT detects that the file contains multiple histograms, it automatically displays a 
dialog box with a list of parameters associated with each stored histogram.  DNA cell-cycle 
analysis is usually done with the red fluorescence integrated or area signal. 
If the data file were in a listmode format, the program would follow this dialog with further gating 
options. 
   
�� Click OK to close the Choose Histogram dialog box. 

�� In the Edit menu, choose “File Batch Settings…” 
 

 

Another way to edit the File Batch Settings is to click on the File Batch control’s “pencil” icon.  
 

In this step, you are going to configure the File Batch processor to perform an Auto Analysis and save 
the report for each file. 
  

�� From the drop-down Analysis listbox, select “Auto-analyze” (see graphic above).  

�� Check the Save Report option (see graphic above). 

�� Select the Save Report Path Folder… button and navigate to the desired report folder 
location.  For the DNA diploid files, we want to store the reports in the “Reports” folder under 
the “Diploid Files” folder (see graphic below). 
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Saving your reports in a different folder each day makes the process of selecting the group of 
folders for Phases 2 through 5 much easier.  File management and archival are also easier if all 
the folders are in a single folder or directory.    
 
�� Select Open to store this report pathway and to close the Choose a folder dialog box. 

�� Uncheck the Database and File prompt checkboxes.  

By unchecking the File prompt checkbox, the program will no longer show you a Choose 
Histogram dialog for stacked histogram file formats or the listmode dialogs, for each file loaded.  
The assumption being made by the program is that all the subsequent files have the same type of 
data structure.  If your laboratory is processing files from separate flow cytometers, this 
assumption may not be valid and it would be better to analyze these files separately. 
   
�� Select OK to close the Edit Properties for file processor dialog. 

We are now ready to analyze all the selected diploid files.  In this tutorial section, we are only going to 
analyze two files, but normally there would be considerably more files, justifying all our preparative work.  
Also, keep in mind that we are segmenting these analyses into diploid, tetraploid, aneuploid, etc for 
teaching purposes only.  When DNA histograms are typically analyzed, no such segmentation is 
necessary or desirable. 
 

�� In the File Batch control, click the Redo button to process the first file (see graphic below). 
 

  

�� Now select the Auto-advance button to analyze the remaining files (see graphic below). 
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We have now analyzed all the files originally selected and stored their associated reports into the 
appropriate folder.  In the next phase we will look at each of these stored reports, determine 
whether Auto Analysis made any mistakes, and then take the appropriate actions. 
 
We need to reset these File Batch properties in order that the program doesn’t prematurely start 
analyzing and saving reports when we start the next tutorial section. 
 
�� Choose either File Batch Settings from the Edit menu or click on the “pencil” edit button on 

the File Batch control. 

�� Select “No analysis” from the Analysis drop-down listbox. 

�� Uncheck the Save Report option. 

�� Recheck the File prompt option. 

�� Click on OK. 

 
 

 
This completes Phase 1. 
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Phase 2 – Initial Review 
 
It is important to review each model fit to catch any mistakes the automatic analysis might have made.  
Adopt a reviewing style that can reliably detect not only major mistakes, but subtle ones as well.  In 
Phase 1, we created two reports in the “Reports” folder under “Diploid Files”.  Now in Phase 2, we will 
inspect and possibly correct each of these reports.  Phase 2 is really the hard part of cell cycle analysis 
and therefore will receive appropriate emphasis in these training tutorials. 
 
We will select all the reports just created in Phase 1 and then appropriately configure the Report Batch 
Processor.  We then will load each report and discuss the analysis in detail.  
 

�� From the File menu, choose Open -> Report... 

�� Navigate to the “Diploid Files\Reports” folder and multiple-select all of the reports. 

If you don’t see any saved reports in this folder, you are either not in the right folder or you didn’t 
configure the File Batch control properly in Phase 1.  

 
�� Select Open. 

�� Choose Report Batch Settings… from the Edit menu or click on the Report Batch control’s 
edit button. 
 

 

When the program detects that two or more reports were selected, it displays the Report Batch 
control and hides the File Batch control.  Both of these controls look alike, but you can easily 
verify which one is on the desktop by putting the cursor over the control’s edit button.  The 
balloon help will let you know which one is present.  In addition, the default position of the Report 
Batch control is to the right of the File Batch control. 

 
�� Select “No analysis” in the Analysis drop-down listbox.  

We have already done the initial analysis in Phase 1.  In Phase 2 we are only evaluating and 
potentially fixing the stored reports. 

   
�� Choose “Re-save Reports” from the Save Reports drop-down listbox.  

We need to “re-save” to make sure that any changes will be stored.  It is possible to manually 
save the reports, but activating this option eliminates the possibility of forgetting to save the report 
after making changes. 
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The other option, “Auto-name and re-save”, is normally not necessary.  A special report-naming 
algorithm is used to convert the file name to a report name.  If old reports need to be renamed 
using this algorithm, the “Auto-name and re-save” option can be used instead. 
 
�� Leave the rest of the options in their default states as shown in the figure above. 

�� Click OK to save the settings and close the dialog. 

�� Let’s now examine the first report. 

 
 

 
 
We have annotated the above report with numbers and letters.  These labels represent the approximate 
position of your focus and eye position when evaluating the report.  The model fit graphics is scanned in 
a left-to-right direction and the equations, top-to-bottom.  We will begin these tutorials with just a few 
observations, but as we proceed, the number of these potential focus spots will increase.  As we discuss 
these observations, any relevant analysis rule will be described.  A copy of the complete rule set is in 
Appendix 1 of these training tutorials.  To keep these tutorials short and to the point, we will only discuss 
some of the more pertinent focal spots for the current histogram.  We’ll occasionally add a spot with the 
label “?” for review purposes.  When you see these labels, try to remember the previously presented 
important observations points.  If you can’t remember, go back and review. 
 

1.  The histograms in this tutorial have two internal standards, chicken and trout erythrocytes.  
These standards are useful for histogram alignment as well as detecting DNA hypodiploid ploidy 
patterns.  We highly recommend their routine use for fresh/frozen types of preparations.  When 
you look at these standards, evaluate their quality of fit, position and height.  If the model didn’t fit 
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the standard well, you might have to move or resize the standard’s associated range.  The rule 
regarding ranges is, II.B.2 “Do not change a range setting unless it is absolutely necessary to do 
so”.  In an earlier tutorial, you were instructed to load a previously stored Auto Analysis 
configuration file.  The Auto Analysis Settings contain important information on the internal 
standards, including their expected locations.  

 
Beneath each major peak in the DNA histogram should appear a black triangle.  This triangle 
represents a statistically significant peak that satisfies additional filters (see Part D).  Occasionally 
the peak finding algorithm will miss one of the standards because its concentration was too low or 
the debris was too high.  This type of error is important to detect since it can dramatically affect 
what type of model Auto Analysis selected.  If the program misses one of the standards and the 
standard is visible, reposition the associated ranges about their appropriate peaks and click on 
the Fit button.   If the standard is not visible (no black triangle), go to the Quick Model Editor in 
the Edit menu and appropriately change the number of standards; then click on the Fit button. 

 
The standards should be in consistent absolute position.  If they’re not, either the histogram was 
not acquired properly or there may be an additional DNA hypodiploid peak overlapping one of the 
standards.  If the final concentration of standards is made consistent, the relative heights of the 
standards to the other peaks provides additional information about the final cellular concentration.  
If a mistake was made in concentration, many times it is evident by this type of comparison.  If 
one of the standards, normally the trout, is much higher than the other standard, the presence of 
a DNA hypodiploid population should be suspected.  

 
��The standards for this histogram have an appropriate fit, position and relative height.  

 
2.  To make an appropriate DNA ploidy determination for the histogram, the position of the DNA 
diploid G1 peak must be identified.  The default color scheme for ModFit LT gives the DNA diploid 
G1 and G2 peaks a color of red, making their identification obvious.  The rule regarding the 
position of the DNA diploid G1 is, I.F. “The position of the diploid G0G1 peak should always be 
placed in about the same channel.  For 256 channel histograms the recommended location is 
channel 50.”   
 

��The position of the DNA diploid G1 peak is appropriate for this example. 
 

3.  The X-Zoomed graphic should be centered about the DNA diploid G1 peak.   DNA near 
hyperdiploid peaks will be most evident in this graph.  The analysis rule to follow regarding this 
type of ploidy pattern is, II.B.1.d “Choose a near-diploid model if the two G0G1 peaks can be 
clearly distinguished and the resulting fit seems appropriate”.   
 

��In this case, there is no split peak or other evidence of another DNA aneuploid 
population. 

 
4.  After the DNA diploid G1 peak has been identified and there is no evidence of a near 
hyperdiploid population, the associated G2 population should be inspected.  If the peak finding 
algorithm has marked this peak as a significant peak that also satisfies your peak criteria 
(presence of black triangle), it will let the program independently find the G2 position (floating). 
Otherwise, it will calculate the G2 population’s position based on the G1 position (dependent) and 
the Linearity Factor. Normally you won’t need to be aware of this logic, but occasionally it may 
be necessary to change the G2 position’s dependency (see the next example file).   
 
The G2 standard deviation is always calculated from the G1’s standard deviation.   

 
 

��The G2 position and quality of fit is appropriate. 
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a.  Total BAD (Background Aggregates and Debris) is defined as the fraction of the histogram 
from the lowest G1 to the highest G2 that is either debris or aggregates.  Use the %Total BAD 
estimate as a histogram acceptance criteria for S-phase reliability.  Recommended %Total BAD 
value is <=30%. 
 

��The %Total BAD estimate for this histogram is quite low and therefore acceptable.  
 

b.  If the model has internal standards, there will be a few additional equations added to the list, 
providing useful statistics.  The absolute position, DI and Dip G1 ratio are important 
characteristics to examine, especially if the program is configured to determine its DNA ploidy 
based on one of the standards (see Auto Analysis Settings).  If the histogram is shifted either to 
higher or lower intensity levels, the DI and Dip G1 ratio can reassure you that the identification of 
the standards was correct. 

 
��The standard’s statistics are all within reasonable ranges. 

 
c.  The %Debris and %Aggregates are related to %Total BAD and are particularly useful when 
the %Total Bad is elevated.  They provide important information targeting a particular problem in 
sample preparation.  For example, if the %Aggregates estimate is quite high, it may be that you 
should consider vortexing your samples more vigorously. 
  

��Both %Debris and %Aggregates are quite low and acceptable. 
 

d.  The “All cycle events” and the average “Cycle events per channel” are very important 
histogram quality measurements.   Many times not enough counts are accumulated for optimal 
cell cycle analysis.  Simulation studies indicate that an average “Cycle events per channel” of 100 
or more is necessary for accurate S-phase estimation.  In some cases, over 20,000 events are 
necessary to meet that requirement. 
 

��The “All cycle events” and “Cycle events per channel” are quite acceptable. 
 

e.  RCS (Reduced Chi-Square) is a measurement of the model fit quality. RCS values of greater 
than five may indicate that there is a population that is not being fit adequately.  Elevated RCS 
values are generally associated with 1) inappropriate starting location of the debris model 
component, 2) non-Gaussian G1 peaks, 3) missing model components for aneuploid peaks 
and/or 4) non-linear amplifiers.  If you see a high RCS value, try to find the reason and correct it if 
you can. 
 

��The RCS value is within reasonable limits for this example. 
 
We have spent a lot of time describing these points of focus for this histogram, but haven’t done much to 
correct anything.  The Auto Analysis algorithm should be correct about 90% of the time.  The approach 
we are trying to teach is targeted at reliably finding those 10% failures and then correcting them in a 
reproducible manner. 
  

�� Click the Next Batch item button on the Report Batch control (see figure below).  
 

  

The system will automatically save the current report and then load the next one. 
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1.  Always check to make sure the debris model component starts at the appropriate beginning of 
the debris.  Some flow cytometry discriminators accumulate a few events in these low channels, 
which can cause the debris range detection system to fail. This leakage normally occurs if the 
discriminator is set on a parameter other than the DNA content parameter.  If the debris 
component doesn’t start at the correct channel, it can affect the overall debris fit, which can 
ultimately affect all the other estimates.  The debris range rule is II.B.2.a, “The beginning of the 
debris range should correspond to the channel with the highest debris counts.”  If the debris 
model component doesn’t start at the correct position, move the debris range to the appropriate 
position. 
 
The discriminator setting should be as low as possible.  The very early debris channels (2 through 
5) contain rich information concerning the underlying shape of the debris and therefore should not 
be eliminated by excessive discriminator thresholding (Rule:I.C, “Events should be discriminated 
on the DNA fluorescence parameter only.  The discriminator level should be as low as possible 
without creating a debris peak that is greater than the highest G0G1 peak.“). 
 

��The debris component starts in the appropriate location for this example. 
 
?.  Try to remember the points previously discussed about internal standards (see preceding 
report). 
 
2.  If there is an identified peak at the DNA diploid G2 location and there are a significant number 
of aggregates, the fitted G2 position may end up being inappropriate.  Normally the aggregate G1 
doublets should align with the G2 position.  If they don’t align, the fit can be improved by using the 
Quick Model Editor to force the G2 to be dependent on the G1 (Rule: II.B.a.2, “If a G2M peak is 
clearly visible and well-defined, allow its mean to be fitted (float) unless there is another 
overlapping population.”). 
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a. If there is a question on whether the G2’s position is correct, examine the G2/G1 ratio.  
Normally the ratio will be between 1.95 and 2.0. 
 

��The G2 is not aligned with the doublets and its G2/G1 ratio is high, 2.10.  To correct 
this subtle problem follow the steps below: 

 
�� Choose the Edit menu and select “Quick Model Editor…”. 

�� Uncheck the “Cycle1 G2M Visible” option. 

�� Click on OK. 

�� Click on the Fit button.  

��The cell cycle fit still isn’t perfect, but it should improve when we find the optimal 
Linearity Factor in Phase 3. 

 
3.  Examine the 6C and 8C locations of the histogram.  The Y-Zoomed Graphic is essential for 
visually inspecting the histogram for the presence of triplet(6C) and quadruplet (8C) aggregate 
peaks.  As will be discussed in the next tutorial, the relative heights of these two peaks are 
important for the detection of low levels of DNA tetraploid cells. 
 
Take a moment to appreciate the decreasing frequency of higher order aggregate peaks (see 
graph below). 
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Appreciating this decreasing pattern of higher order aggregates is an important step in developing 
your skill for detecting low levels of DNA tetraploid populations (next tutorial). 
 

��There is no evidence of another aneuploid population.  The quality of the aggregate fit 
will probably improve in Phase 3. 

 
�� Press the Redo button on the Batch Report control to force a re-saving of the report. 

Normally, the system will automatically detect that the last report needs re-saving, but it is 
prudent to force the re-save operation to be sure. 

 
This concludes Phase-2.   

 

Line to show expected 
relative aggregate peak 
heights.
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Phase 3 – Automatic Linearity Factor Detection 
 
Both the dependent G2 positions and the aggregate model component are highly dependent on the 
Linearity Factor, defined as the ratio between the DNA diploid G2 and G1 positions.  Since S-phase 
estimates are dependent on G2 as well as aggregates, it’s important to determine the Linearity Factor 
in a reproducible manner.  The AutoLinearity feature in ModFit LT will find the Linearity Factor that 
minimizes the RCS over a specified range.  The default range is 1.90 to 2.05.  The AutoLinearity 
algorithm looks at every Linearity Factor in the defined range at increments of 0.01 units, storing the 
Linearity Factor with the lowest RCS.  Unfortunately, this process is computationally intensive and 
consequently should be done in the Batch Report processor. 
 

�� Click on the Report Batch control’s “pencil” button or choose Report Batch Settings from 
the Edit menu (see graph below).  
 

 

�� Select “Fit and do autolinearity” from the Analysis drop-down listbox. 

�� Leave the “Re-save” Save Report option selected. 

�� Select OK. 

�� Click on the “First Batch Item” button on the Report Batch control (see graph below). 
 

 

The program will immediately start analyzing the first report looking for the optimum Linearity 
Factor.  In the lower-left corner of the status bar, you can monitor its progress. 
 
�� Select the “Auto Advance” button on the Report Batch control to analyze the rest of the 

reports.  

End of Phase 3. 
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Phase 4 –Final Review 
 
Since Phase 3 can significantly change the quality of the cell cycle fits, it’s important to perform a final 
review on all the reports.  We will again use the Report Batch control to help us perform this task 
efficiently.   
 

�� Click on the Report Batch control’s “pencil” button or choose Report Batch Settings from 
the Edit menu 

�� Select “No analysis” in the Analysis drop-down listbox. 

�� Select “Don’t re-save report” from the Save Report drop-down listbox. 

You don’t really need to turn off the automatic saving of reports options, but since most of the 
reports are going to be acceptable, you might consider manually saving just those reports that 
need further adjusting.  To manually save a report use the Save tool button. 
 
�� Click on OK. 

�� Select the “First Batch Item” button on the Report Batch control. 

�� Inspect the first report using the method described in Phase 2. 

The first report should look just like the one in Phase 2 since not much changed with the new 
optimum Linearity Factor. 
 
�� Select the “Next Batch Item” button on the Report Batch control. 

Notice that the fit of the aggregate component is much better with the optimized Linearity Factor 
and note that the RCS is much lower as well. 
 

This is the end section G: DNA Diploid Tutorial. 
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Part H - DNA tetraploid files – 15 minutes 

 
In this section of the tutorial, you will analyze DNA tetraploid files following the four-phase analysis 
procedure.  DNA tetraploid files can be very difficult to distinguish from DNA diploid histograms if the 
aneuploid fraction is very low.  We will present a technique that should make this decision relatively easy 
and reliable.  There are also a few specific modeling issues regarding DNA tetraploid models that need 
further explanation.   
 

Note: The basic instructions for analysis are repeated to assist your learning each one.  However, 
some of the notes and observations will be different. 

 
Phase 1 – Perform Auto Analysis and generate report files. 
 
In this step, you are going to select all of the files for analysis, configure the File Batch processor to 
perform an Auto Analysis, and save a report for each analyzed data file. 
 

If you already have a report on the desktop that has the X and Y zoom graphics, you don’t need 
to load in the report template.  If for some reason you have closed ModFit LT between this 
section and the last one, you will need to open the report template as you did in the Part G – DNA 
diploid files tutorial.    

  
�� Click on the File toolbar button. 

�� Navigate to the “Tetraploid Files” folder.  

The data files are under folders specific for each part of the tutorial.  The folder structure is shown 
on page A-1 of the manual. 
 
�� Multiple-select the data files listed in the Files window (see graphic below). 

 

 

�� Click the Open button. 

�� Select “FL2-A” as the analysis parameter. 

�� Click OK to close the Choose Histogram dialog box. 

�� In the Edit menu, choose “File Batch Settings…”  
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�� In the Edit Properties for File processor dialog, choose “Auto-analyze” and enable Save 
Report checkbox as show in the figure below.  

 

�� Click on the “Folder…” button and navigate to the desired report folder location.  For the DNA 
tetraploid files, this will be the “Reports” folder under the “Tetraploid Files” folder (see graphic 
above). 

�� Click the “Open…” button in the Choose a Folder dialog box to store this report pathway and 
to close the dialog box. 

�� In the Edit properties for File Processor dialog, be sure that the “Database prompt” and 
“File prompt” checkboxes are un-checked (see graphic above).    

�� Click OK. 

�� Click the Redo button on the File Batch control to process the first file. 

�� Click the Auto-advance button to analyze the remaining files. 

We now need to reset the File Batch control’s properties. 
 

�� Choose either File Batch Settings from the Edit menu or click on the “pencil” edit button on 
the File Batch control. 

�� Select “No analysis” from the Analysis drop-down listbox. 

�� Uncheck the Save Report option. 

�� Recheck the File Prompt option 

�� Click on OK. 

 

This completes Phase 1. 
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Phase 2 – Initial Review 
 
Let’s now review all these reports. 
 

�� From the File menu, choose Open -> Report... 

Notice that the program took you to the folder where you had previously chosen to save the 
reports.  If it didn’t navigate to the “Tetraploid Files\Reports folder. 

 
�� Multiple-select all the reports. 

�� Click the Open button.   

�� Choose Report Batch Settings… from the Edit menu or click on the Report Batch control’s 
edit button.  

�� Select “No analysis” in the Analysis drop-down listbox.  

�� AutoAddZoomObjects should be disabled. 

�� Choose “Re-save Reports” from the Save Reports drop-down listbox.  

�� Leave the rest of the options in their default states.  

�� Click OK to save the settings and close the dialog. 

�� Let’s now examine the first DNA tetraploid report.  
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?.  Try to remember all the points about the start of the debris and internal standards as well as 
the expected location of the DNA diploid G1 peak. 
 
1.  A large population at 4C (channel 90) is suggestive of a DNA tetraploid population.  Further 
evidence to support this contention is the absence of a DNA diploid G2 peak.  The diploid G2 is 
disabled for DNA tetraploid models because of the general rule:II.B.1.a.1, “If two model 
components are of similar shape and are highly overlapped (>75%), it may be necessary to add 
additional constraints to the model or, in the worse case, disable the model component of lesser 
importance.”  In this case, the DNA diploid G2 overlaps the DNA tetraploid G1 and is of lesser 
importance and therefore is automatically disabled for DNA tetraploid models.  
 

��The DNA tetraploid model is appropriate for this histogram. 
 

2,3.  The 6C aggregation peak (2) is quite small compared to the larger DNA tetraploid G2 peak 
(3).  This example is an obvious DNA tetraploid histogram because of the large size of the 4C 
peak.  As we will see in the next report, the identification of DNA tetraploids becomes more 
difficult as the aneuploid fraction decreases.  A good rule to employ regarding DNA tetraploids is 
Rule: II.B.1.b.2, “(Select a tetraploid model if) there is another peak at 8C that cannot be 
explained as an aggregate.  a.  Consider the 8C peak to be an aggregate if it is less than the 6C 
peak.”  Visualizing the slowly decreasing frequency of higher order aggregate peaks (see line in 
above graph) can help to detect these DNA tetraploids. 
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Also, note that because the peak at (3) did not satisfy the Peak Finder’s criteria or filters, the 
DNA tetraploid G2 position is dependent on G1.  Although the fit is not good right now, it is likely 
to improve in Phase 3. 
 
a.  If the DNA diploid G2 is disabled, why is there a 8% for its estimate?  Because the DNA 
tetraploid model does not have a diploid G2, the tetraploid G1 is slightly larger than it should be 
because it is also capturing DNA diploid G2 counts.  This effect causes the DNA tetraploid S-
phase to be slightly underestimated.  To compensate for low bias, the Edit->Options and 
Configuration… dialog has the setting, “Dip G2M fraction”.  As you might expect, this setting is 
currently 0.08 or 8%.  For DNA tetraploid models, all affected equations are adjusted 
appropriately with this factor. 
 
b.  When a G2 is dependent, the G2/G1 ratio becomes equivalent to the Linearity Factor, which 
is currently 1.95.  

 
��Auto Analysis has appropriately selected a DNA tetraploid model for this histogram.   

 
  

�� Click the Next Batch item button on the Report Batch control. 

?.  Try to recount the previous discussion on 6C and 8C peaks.  Can the peak at 8C, channel 
210, really be just an aggregate? 
 
a.  Also, note the rather large percentage for the DNA diploid G2.  With solid tumors, very rarely 
do G2’s exceed 10%.  This elevated value is further evidence that the DNA diploid model 
selection was incorrect. 
 

a

?

a

?
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��The wrong model was selected in Auto Analysis.  This histogram should be modeled 
with a DNA tetraploid model. 

 
Let’s now correct the problem. 
 

�� Click on the Mod toolbar button (see graphic below). 

 

�� In the Edit Properties for Manual Analysis dialog box, change the “Number of cycles” value 
to "2" and select "Dip Tet" from the “Model template” drop-down listbox (see graphic below). 

 
 
�� Click on the OK button to close the dialog box and load the new model. 

�� Verify the position of the model ranges displayed on the report (see graphic below). 
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The only two ranges that need adjusting are the “An1 G1” and “An1 G2” ranges.  They both need 
to be moved slightly to the right.   
 
�� Click on the Fit toolbar button. 

The histogram should now be fitted with the DNA tetraploid model. 
 

�� Click on the Save toolbar button or the Report Batch control’s Redo button to make sure this 
changed report is saved. 

 
This concludes Phase 2.   
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Phase 3 – Automatic Linearity Factor Detection 
 
Let’s now find the optimum Linearity Factor all our stored reports. 
 

�� Click on the Report Batch control’s “pencil” button or choose Report Batch Settings from 
the Edit menu (see graph below).  

�� Select “Fit and do autolinearity” from the Analysis drop-down listbox. 

�� Leave the “Re-save” Save Report option selected. 

�� Select OK. 

�� Click on the “First Batch Item” button on the Report Batch control. 

�� When the first report is done processing, select the “Auto Advance” button on the Report 
Batch control to analyze the rest of the reports.  

End of Phase 3. 
   
Phase 4 –Final Review 
 
Now for our final review…   
 

�� Click on the Report Batch control’s “pencil” button or choose Report Batch Settings from 
the Edit menu 

�� Select “No analysis” in the Analysis drop-down listbox. 

�� Select “Don’t re-save report” from the Save Report drop-down listbox. 

�� Click on OK. 

�� Select the “First Batch Item” button on the Report Batch control. 

�� Inspect the first report using the method described in Phase 2. 

Notice that the DNA tetraploid G2 is now better positioned than it was before Phase 3. 
 
�� Select the “Next Batch Item” button on the Report Batch control. 

Notice that the 6C aggregates are now better positioned than earlier and the RCS is much lower. 
  

 
This is the end section H: DNA Tetraploid Tutorial. 
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Part I -  DNA aneuploid files – 40 minutes 
 
DNA aneuploid histograms are slightly more difficult to interpret than DNA diploids because they have an 
additional cell cycle, creating more complexity to histogram interpretation and analysis.  However, the 
four-phase approach to this type of analysis is still the method of choice.  
 
Phase 1 – Perform Auto Analysis and generate report files. 
 
In a manner similar to the preceding sections, we will first load our DNA report template (if necessary), 
select the DNA aneuploid files, properly configure the File Batch control and then process all the files 
using Auto Analysis. 
 

�� Click on the File menu and choose Open Report....  

�� Navigate to folder under “Data”, select the file, “DNAReportTemplate.mfl” then click on Open. 

�� Click on the File toolbar button (first tool button on left). 

�� Navigate to the “Aneuploid Files” folder.   

�� Multiple-select all of the aneuploid example files (see figure below). 
 

  

 
Multiple selection can be done in several ways.  In the previous sections, we used a “block 
selection” technique.  Another technique called the “marquis box” method is sometimes more 
efficient.  Place the cursor in the white space just to the right of the first file name.  While holding 
the left (PC only) mouse button down, drag the mouse pointer diagonally across the files of 
interest.  You will see a marquis box with dotted lines over the encompassed selected file names.  

 
�� Click the Open button. 

�� Select “FL2-A” as the analysis parameter. 

�� Click OK to close the Choose Histogram dialog box. 

As in earlier tutorials, we will configure the File Batch control to automatically analyze all the files and 
save the reports. 
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�� From the Edit menu, choose “File Batch Settings…” or select the File Batch control’s 
“pencil” button. 

�� From the drop-down Analysis listbox, select “Auto-analyze”.  

�� Check the Save Report option. 

�� Select the Save Report Path Folder… button and navigate to the desired report folder 
location.  For the DNA aneuploid files, we want to store the reports in the “Reports” folder 
under the “Aneuploid Files” folder. 

�� Select Open to store this report pathway and to close the Choose a folder dialog box. 

�� Uncheck the Database and File prompt checkboxes.    
 
�� Select OK to close the Edit Properties for file processor dialog. 

 
Now we are able to automatically process the files. 

 
�� In the File Batch control, click the Redo button to process the first file.  

�� Now select the File Batch control’s Auto-advance button to analyze the remaining files. 

All the files have now been analyzed and the reports saved. 
 

We now need to reset these File Batch properties in order that the program doesn’t prematurely start 
analyzing and saving reports when we start the next tutorial section. 

 
�� Choose either File Batch Settings from the Edit menu or click on the “pencil” edit button on 

the File Batch control. 

�� Select “No analysis” from the Analysis drop-down listbox. 

�� Uncheck the Save Report option. 

�� Click on OK. 

 
 
This completes Phase 1.  
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Phase 2 – Initial Review 
 
As we have seen in the previous sections, it is possible for the automatic analysis algorithms to make 
mistakes.  The number of mistakes will potentially increase as the complexity of the DNA histogram 
increases.  When you notice that there are two or more additional cell cycles, be more alert to possible 
analysis problems and carefully employ the left-to-right method of evaluating the fit. 
 
Let’s load in the reports. 
 

�� From the File menu, choose Open -> Report... 

�� Navigate (if necessary) to the “Aneuploid Files\Reports” folder and multiple-select all of the 
reports. 

If you don’t see any saved reports in this folder, you are either not in the right folder or you didn’t 
configure the File Batch control properly in Phase 1.  

 
�� Select Open. 

�� Choose Report Batch Settings… from the Edit menu or click on the Report Batch control’s 
“pencil” icon. 

�� Choose ‘No analysis’ from the Analysis drop-down listbox.   

�� Choose “Re-save report” from the Save Report drop-down listbox. 

�� Leave the rest of the options in their default states. 

�� Click OK to save the settings and close the dialog. 

�� Let’s now examine our first DNA aneuploid report. 

 
In these tutorials, we are only identifying a few new focus spots for each presented report.  We 
occasionally will ask you via the “?” spot to review previously discussed material.  However, when 
you evaluate the report, you need to consider everything we have covered, whether it is marked 
or not.  This type of rigorous approach will generally detect most of the subtle problems that lead 
to variable results.  
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?.  Try to recall the points made about examining the debris fit. 
 
1.  More than half of the DNA aneuploid populations are obvious when they occur.  The default 
color for the first aneuploid G1 and G2 populations is yellow.  
 

��An obvious single aneuploid population is present and Auto Analysis chose the 
correct model. 

 
2.  Always try to identify the DNA diploid G2 population.  The question you need to ask yourself is 
whether the DNA diploid G2 is being fit appropriately or not.  If it is not, you might need to change 
the model to a DNA tetraploid model (Rule:II.B.1.b.3, “Choose a tetraploid model over an 
aneuploid model if the diploid G2M overlaps too significantly with an aneuploid G1.” and 
Rule:II.B.1.b.3.b, “Inappropriate fits of the diploid G2M are usually associated with a zero or very 
high calculated percentage or a location that results in a G2/G1 ratio outside the expected 
range.”). 
 

��The DNA diploid G2 population is modeled well.  Since this G2 is dependent on the 
G1, the quality of the fit will improve in Phase 3 when a more optimal Linearity Factor 
is determined. 

   
a.  On the average, the aneuploid fraction (AF) will be between 40-60%. 
 

��The Aneuploid Fraction (AF) is 62%.  
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b.  Always check the DNA Index of the DNA aneuploid population to make sure it corresponds to 
the fitted graphics.  
 

��The DI is 1.6. 
 

c.  The total aneuploid S-phase is the key analysis result regarding DNA aneuploid S-phases.  If 
there are multiple DNA aneuploid populations, this value will be the weighted average of all the 
aneuploid S-phases. 
 
The total S-phase result is only included for backward compatibility.  It is not recommended to 
report this value since it is highly influenced by AF because it is a weighted average that includes 
the DNA diploid S-phase.  Because the variability of AF approaches a high %CV of 20, the 
prognostic strength of this variable is unreliable. 
 

��The Total Aneuploid S-phase is 4.9%. 
 

?.  Try to remember the previous discussion about “Cycle events per channel”.  Does this 
histogram have an optimal number of events? 
 
You can still quantify S-phase with sub-optimal numbers of counts but the uncertainty of the 
estimate will be higher. 

 
Auto Analysis seems to have done a reasonable job with this histogram.  Let’s look at the others. 
 

�� Click the Next Batch item button on the Report Batch control. 

?
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2
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?.  Try to remember our previous discussion about internal standards.  If the internal standards’ 
concentrations are the same as in the previous files, what can be deduced about the cellular 
concentration? 
 
1.  There are a number of modeling ramifications regarding DNA near hyperdiploid histograms.  
Since the DNA diploid and aneuploid S-phase populations overlap so significantly, the DNA 
diploid S-phase is automatically inactivated when Auto Analysis detects that the DI is less than 
or equal to 1.3 (Rule:II.1.a, “If two model components are of similar shape and are highly 
overlapped (>75%), it may be necessary to add additional constraints to the model or, in the 
worse case, disable the model component of lesser importance.” and Rule: II.1.d.2, “If the DI is 
between 0.7-1.0 or 1.0-1.3 disable the diploid S-phase and make both G2’s dependent”). 
 
An easy way to inspect and change many of these activation and dependency model attributes is 
by the Quick Model Editor under the Edit menu. 
 

��A DNA near hyperdiploid G1 population is present.  Auto Analysis picked the correct 
model. 

 
2.  Because of the above stated Rule:II.1.d.2, both the DNA diploid and aneuploid G2 peaks are 
dependent on their respective G1 peaks.  Since both G2’s are dependent, they may not yet fit the 
data properly because the optimal Linearity Factor has not yet been calculated. 
 

��The DNA diploid and aneuploid G2’s are not fitted well but that situation should 
improve in Phase 3. 

 
If you run into a situation where you want to make sure you check something in the final review 
phase, a useful technique is to use the annotation reporting objects to call attention to that aspect 
of the report.  After the final review, the annotation can easily be removed. 

 
a.  Because we are using a near diploid model, the DNA diploid S-phase is inactivated and 
appears as zero in the evaluated equation list. 
 

��The DNA diploid S-phase is zero as expected. 
 

We have found nothing to change for this report.  Let’s move on to the final report for this tutorial section. 
 

�� Click the Next Batch item button on the Report Batch control. 
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?.  Try to recall the discussion about the DNA diploid G2.  Should we be worried that it is not 
perfectly positioned?  Why? 
 
1.  We always use a convoluted (broaded) single rectangle for the S-phase model component 
when analyzing solid tumor DNA histograms (Rule:II.B.a.3, “Always model S-phase as a single 
broadened rectangle.”).  Broadened rectangles are advantageous since they are not as sensitive 
to the presence of small G1 shoulders or other S-phase “imperfections” as some of the other 
proposed S-phase components (broadened trapezoids, polynomials and multiple compartments).  
 
2.  A second DNA aneuploid population is assigned, by default, a slightly darker yellow.  In this 
example, the change in color should be the initial tip-off that a second aneuploid population has 
been detected by the Auto Analysis procedure.  Why did the system make this choice?  We feel 
that it is important to know how Auto Analysis decides when a peak represents a valid G1 
population.  This knowledge can be used to control and tailor the program’s operating 
characteristics to efficiently and reliably analyze DNA histograms.  Once the technical reasons for 
this decision are presented, we’ll discuss what you should do about this particular situation.    
 
The relevant configuration settings in Auto Analysis are the “G1 threshold” and the “Tetraploid 
G2M threshold”.  In order for the system to assign a peak as a valid G1 peak, its estimated area 
must equal or exceed the “G1 threshold”.  In this case, the “G1 threshold” is set to 5%, which is 
certainly less than the peak at channel 170.  Since this peak is also a possible G2 for the first 
aneuploid population, Auto Analysis must determine whether it is too large to be a valid G2.   
The important setting for this determination is the “Tetraploid G2M threshold”.  This particular 
histogram’s peak at channel 170 is estimated to exceed the current G2M threshold setting and 
therefore Auto Analysis has assigned it to be the G1 of another aneuploid population. 
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Did Auto Analysis make the right choice?  If you look carefully at this peak, it doesn’t look like a 
typical G2.  It’s large and it appears split.  It may indeed represent a second aneuploid population, 
but the problem is that because it is so far upscale, the program cannot model its S-phase and 
G2.  The rules that pertain to this situation are, Rule:II.B.1.c.1, “Only choose this model 
(Aneuploid) if the potential aneuploid’s G0G1 cannot be explained as an aggregate or some other 
part of another cycle (e.g. G2M).” and Rule:II.B.1.c.2, “and there are adequate channels to model 
the entire cycle”. 
 
If there are not enough channels to model the S-phase and G2, then the results will be in error 
and it is better to ignore these results than to try to include them. 
 

��The correct model should be one aneuploid population.  We need to adjust the model. 
 

We’ll correct the model in just a moment.  Let’s finish up our focus areas. 
 
a.  The second way to identify the second aneuploid population is by inspection of the model 
equation lists. 
 
?.  Try to recall the definition of Total Aneuploid S-phase.  Why is this value different from the 
Aneuploid 1 S-phase? 

 
�� Click on the Choose Model toolbar button (see graphic below). 

 

 

�� Choose “2” from the “Number of cycles” drop-down listbox (see graphic below). 
 

 

�� If necessary, choose “Dip Ane” from the “Model templates” drop-down listbox. 

�� Click OK. 

�� Make sure the ranges are as shown below: 
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The only two ranges necessary to adjust was the Dip G2 (moved a little to the right) and the An1 
G2 (widen to accommodate the entire peak).  Remember the range moving rule, “Do not change 
a range setting unless it is absolutely necessary to do so.” 
 
�� Click on the Fit toolbar button. 

If you did the steps properly, there should now only be one aneuploid population. 
 
�� Click on the Redo Report Batch control button or click on the Save toolbar button to make 

absolutely sure this modified report has been saved. 

  
This concludes Phase-2.   
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Phase 3 – Automatic Linearity Factor Detection 
 
Let’s now find the optimum Linearity Factor all our stored reports. 
 

�� Click on the Report Batch control’s “pencil” button or choose Report Batch Settings from 
the Edit menu (see graph below).  

�� Select “Fit and do autolinearity” from the Analysis drop-down listbox. 

�� Leave the “Re-save” Save Report option selected. 

�� Select OK. 

�� Click on the “First Batch Item” button on the Report Batch control. 

�� When the first report is done processing, select the “Auto Advance” button on the Report 
Batch control to analyze the rest of the reports.  

End of Phase 3. 
   
Phase 4 –Final Review 
 
Now for our final review…   
 

�� Click on the Report Batch control’s “pencil” button or choose Report Batch Settings from 
the Edit menu 

�� Select “No analysis” in the Analysis drop-down listbox. 

�� Select “Don’t re-save report” from the Save Report drop-down listbox. 

�� Click on OK. 

�� Select the “First Batch Item” button on the Report Batch control. 

�� Inspect the first report using the method described in Phase 2. 

Notice that the DNA diploid G2 is now better positioned than it was before Phase 3. 
 
�� Select the “Next Batch Item” button on the Report Batch control. 

Notice that the aggregates are now better positioned than earlier and the RCS is much lower. 
 
�� Select the “Next Batch Item” button on the Report Batch control. 

Notice that the DNA diploid G2 is better positioned and our change from two aneuploid 
populations to one is present  
 

This is the end section I: DNA Aneuploid Tutorial. 
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Part J – Multiploid / Hypodiploid Files – 15 minutes 

 
We will again use the four-phase approach to analyze these more difficult DNA histograms.  
 
Phase 1 – Perform Auto Analysis and generate report files. 
 
In a manner similar to the preceding sections, we will first load our DNA report template (if necessary), 
select the DNA aneuploid files, properly configure the File Batch control and then process all the files 
using Auto Analysis. 
 

�� Click on the File menu and choose Open Report....  

�� Navigate to folder under “Data”, select the file, “DNAReportTemplate.mfl” then click on Open. 

�� Click on the File toolbar button (first tool button on left). 

�� Navigate to the “Multiploid_Hypodiploid Files” folder (see figure below).   

�� Multiple-select all of the example files (see figure below). 
 

 

�� Click the Open button. 

�� Select “FL2-A” as the analysis parameter. 

�� Click OK to close the Choose Histogram dialog box. 

As in earlier tutorials, we will configure the File Batch control to automatically analyze all the files and 
save the reports. 
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�� From the Edit menu, choose “File Batch Settings…” or select the File Batch control’s 
“pencil” button. 

�� From the drop-down Analysis listbox, select “Auto-analyze”.  

�� Check the Save Report option. 

�� Select the Save Report Path Folder… button and navigate to the desired report folder 
location.  For the DNA multiploid and hypodiploid files, we want to store the reports in the 
“Reports” folder under the “Multiploid_hypodiploid Files” folder. 

�� Select Open to store this report pathway and to close the Choose a folder dialog box. 

�� Uncheck the Database and File prompt checkboxes.    
 
�� Select OK to close the Edit Properties for file processor dialog. 

 
Now we are ready to automatically process the files. 

 
�� In the File Batch control, click the Redo button to process the first file.  

�� Now select the File Batch control’s Auto-advance button to analyze the remaining files. 

All the files have now been analyzed and the reports saved. 
 

We now need to reset these File Batch properties in order that the program doesn’t prematurely start 
analyzing and saving reports when we start the next tutorial section. 

 
�� Choose either File Batch Settings from the Edit menu or click on the “pencil” edit button on 

the File Batch control. 

�� Select “No analysis” from the Analysis drop-down listbox. 

�� Check the “File prompt” checkbox. 

�� Uncheck the Save Report option. 

�� Click on OK. 

 
 
This completes Phase 1.  
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Phase 2 - Initial Review 
 
Let’s load in these reports and see what Auto Analysis did. 
 

�� Click on Report menu and choose Open -> Report… 

Notice that the program took you to the folder where you had previously chosen to save the 
reports.  

 
�� Multiple-select all the listed reports. 

�� Click the Open button. 

Configure the Report Batch control to efficiently evaluate these reports. 
   

�� Choose Report Batch Settings… from the Edit menu or click on the Report Batch control’s 
“pencil” icon.  

�� Choose ‘No analysis’ from the Analysis drop-down listbox. 

�� Choose “Re-save report” from the Save Report drop-down listbox.  

�� Leave the rest of the options in their default states. 

�� Click OK to save the settings and close the dialog.   

�� Let’s examine our first report. 
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?.  Try to remember when to use the X-Zoomed graphic. 
 
1.  Notice that the second standard, trout erythrocytes, seems elevated compared to the first 
standard. 
 
2 and a.  Notice that the DNA Diploid S-phase is elevated. 
 
3.  There is also an elevated peak at roughly twice the position of the peak identified at (1). 
 
c.  Finally, note that the results associated with the second standard model component shows a 
DI of 0.86 when it normally ranges between 0.78 and 0.80. 
 
All these observations support the conclusion that this histogram has the relatively rare DNA 
hypodiploid DNA ploidy pattern (expected frequency ~2% for breast cancer). 
 
There are a number of modeling ramifications to DNA hypodiploid histograms.  In this particular 
example, since the DNA hypodiploid G1 peak overlaps the trout standard, we must deactivate 
this standard (Rule:II.B.a.1, “If two model components are of similar shape and are highly 
overlapped (>75%), it may be necessary to add additional constraints to the model or, in the 
worse case, disable the model component of lesser importance.”). 
 
This same rule applies to the overlapping DNA hypodiploid and diploid S-phases.  Since the DNA 
diploid S-phase is of lesser importance, it must be deactivated. 
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The difficult part of this histogram interpretation is whether the additional aneuploid population is 
really just part of the DNA hypodiploid cycle.  We need to use another one of our rules to help us 
with this decision (Rule:II.B.1.c.1, “Only choose this model (aneuploid) if the potential aneuploid’s 
G0G1 cannot be explained as an aggregate or some other part of another cycle (e.g. G2M).”).  
Since this additional peak could be the DNA hypodiploid’s G2, we initially reject the Auto 
Analysis decision to add a DNA aneuploid population to the model. 
 
Let’s pick a better model. 
 
�� Click on the Mod toolbar button. 

 
 

�� In the Edit Properties for Manual Analysis dialog box, change the number of standards to 
“1” (see graphic below). 

�� From the Model template drop-down listbox choose “Hyp Dip” (see graphic below). 

�� Select “Use current range positions” from the Range positions drop-down listbox (see 
graphic below).   

If you leave this option set to “Compute range positions”, the program will move all of the ranges.  
Since Auto Analysis calculated most of the populations correctly, it is best to use the “Use 
current range positions” option in order to minimize the number of ranges to move or resize.   
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�� Click on OK. 

�� Only adjust the “An1 G1” and “An1 G2” ranges (see graphic below). 

 

�� Click on the Fit toolbar button. 

The DNA hypodiploid G2 and the aggregates still don’t fit well, but that situation will probably 
improve in Phase 3. 
 
�� Click on the Report Batch control’s Next Batch Item button to load the next report. 
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Although this histogram is quite complex, it is easily interpretable and most of the rules we have 
introduced thus far, will apply.  In many ways, this histogram summarizes practically all that you 
have learned; therefore, we will use it as a final summary.  If you don’t feel comfortable with any 
of the following questions regarding this histogram, go back and review them in the appropriate 
earlier tutorials. 
 
1?.  Start of the debris component.  Is it correct? 
 
2?.  What can be said about the internal standards in this sample? 
 
3?.  Why is this peak assigned to be a DNA diploid G1?  What is a quick way of knowing whether 
a G1 or G2 model component is part of the DNA diploid or aneuploid population? 
 
4?.  Is there any evidence of a near diploid population? 
 
5?.  Can you see the DNA diploid G2?  What does the absence of a DNA diploid G2 peak relate 
to the type of model that is used for peak (5)? 
 
6?, b?, d?.  What are the %AF and DI for this DNA aneuploid G1?  What are the definitions for 
%AF and DI? 
 
7?.  Is this peak a reasonable G2 for the first DNA aneuploid G1?  How do you know it belongs to 
the first DNA aneuploid G1? 
 
8?, e?, f?.  What are the %AF and DI for the second DNA aneuploid G1? 
 

5?1?

2?

3?

4?

6? 7? 9?

a?

c?
b?

e?
d?

f?
g?
h?
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l?

8?
5?1?

2?

3?

4?

6? 7? 9?

a?

c?
b?

e?
d?

f?
g?
h?

i?

j?
k?

l?

8?



Part J – Multiploid / Hypodiploid Files  ModFit LT Training 

(c) 2001 Verity Software House, Inc.  All rights reserved. J-8 Revision: 5/7/2001 

c?.  Why is this S-phase zero?  What rule is being used?  Has the rule been applied to the 
appropriate DNA aneuploid population? 
 
9?.  Is this peak a reasonable G2 for the second DNA aneuploid G1? 
 
a?.  Why is the DNA diploid G2, 8%? 
 
g?.  How is the “Total Aneuploid S-phase” calculated? 
 
h?.  Does this sample have an acceptable level of %BAD?  What is %BAD? 
 
I?.  Are the internal standards in their appropriate locations?  What can be said about the cellular 
concentration assuming the internal standards are always added to a constant final 
concentration? 
 
j?.  If you were going to try to improve your method of preparation, what would you work on most, 
minimizing debris or aggregates? 
 
k?.  Have an adequate number of events been accumulated?  How do you know?  What’s 
optimal? 
 
l?.  Is the quality of the fit reasonable?  When would you suspect that some part of the histogram 
is not being fit properly? 
 
If you feel comfortable answering the above questions, then you have learned what we intended 
to teach.  If you don’t, go back and review the earlier tutorials. 

 
The important observations that relate to our task in Phase 2 are questions: 6, 8 and c.  These 
two aneuploid populations have S-phases that are heavily overlapped and therefore one of the S-
phases needs to be inactivated.  The question to answer is whether Auto Analysis picked the 
correct population to inactivate.  The more dominant aneuploid population is the first one 
according to our estimates of their respective aneuploid fractions; therefore, the second DNA 
aneuploid S-phase should be deactivated, not the first. 
 
In the big scheme of things, this error is rather minor.  However, our intent in this tutorial is to 
teach a method of analyzing DNA histograms that results in different operators obtaining the 
same answer by allowing the rules to guide us during key decision points.  Let’s now correct this 
relatively minor mistake. 
 

��The second DNA aneuploid population’s S-phase should be deactivated and the first, 
activated. 

 
�� Choose “Quick Model Editor…” from the Edit menu. 

�� Scroll down until you see “Cycle2 S-phase” and activate its checkbox. 

�� Inactivate “Cycle3 S-phase”. 

�� Select OK. 

�� Click on the Fit toolbar button. 

�� Click on the Save toolbar button. 

Let’s now look at the last report. 
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�� Click on the Report Batch control’s Next Batch Item button to load the next report.   

 
 
It’s very important to recognize this type of histogram when it crosses your desk.  Occasionally, a 
DNA histogram will be of such quality that it should not be subjected to further examination.  This 
kind of histograms is a waste of your time and if reported, can undermine clinicians’ confidence in 
this technology and can conceivable harm the patient.   The old adage, “Garbage in, garbage 
out”, is particularly relevant for this type of histogram.  You can ask for another sample, but do not 
try to be heroic and make something out of nothing. 

 
 
 
This concludes Phase 2.   

 



Part J – Multiploid / Hypodiploid Files  ModFit LT Training 

(c) 2001 Verity Software House, Inc.  All rights reserved. J-10 Revision: 5/7/2001 

Phase 3 – Automatic Linearity Factor Detection 
 
Let’s now find the optimum Linearity Factor all our stored reports. 
 

�� Click on the Report Batch control’s “pencil” button or choose Report Batch Settings from 
the Edit menu (see graph below).  

�� Select “Fit and do autolinearity” from the Analysis drop-down listbox. 

�� Leave the “Re-save” Save Report option selected. 

�� Select OK. 

�� Click on the “First Batch Item” button on the Report Batch control. 

�� When the first report is done processing, select the “Auto Advance” button on the Report 
Batch control to analyze the rest of the reports.  

End of Phase 3. 
   
Phase 4 –Final Review 
 
Now for our final review…   
 

�� Click on the Report Batch control’s “pencil” button or choose Report Batch Settings from 
the Edit menu 

�� Select “No analysis” in the Analysis drop-down listbox. 

�� Select “Don’t re-save report” from the Save Report drop-down listbox. 

�� Click on OK. 

�� Select the “First Batch Item” button on the Report Batch control. 

�� Inspect the first report using the method described in Phase 2. 

The DNA hypodiploid model fit should look reasonable. 
 
�� Select the “Next Batch Item” button on the Report Batch control. 

Notice that the second DNA aneuploid population has zero percent S-phase now. 
 
It is very rare that the Linearity Factor detection system will create problems and necessitate a 
modeling change, but it can happen.  Thus, you are obligated to recheck every report for this final 
time. 

  
 

This is the end section J: DNA Multiploid_Hypodiploid Tutorial. 
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Part K – Phase 5 - Databasing and Printing Reports – 15 minutes 
 
Now that all your reports have been analyzed by the four-phase method, you can automatically 
reprocess these reports in Phase 5 and generate a complete database of the results and a printout of the 
final reports.  This tutorial will attempt to show you exactly what you need to know to do these important 
tasks. 
 

�� From the Edit menu, choose “Databases…” 

�� Select “Database1” in the listbox (see graphic below). 
 

 

The program supports multiple simultaneous databases.  By default, there is just one database, 
“Database1”, available. 
 
If the current database item is “Standard” then this part of the tutorial has been already done by 
someone else.  Just follow the steps anyway. 
 

We are going to use a previously designed database to import all the database fields. 
 

�� Click on Properties…. 
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�� Check and uncheck the options as shown above. 

The Active checkbox will activate the database for the current modeling session.  We don’t want 
the database system to prompt us to save a record and the Viewer allows us to inspect the 
records of the database.  
 
�� Click on the Choose button (see graphic above). 

�� Navigate to the “Standard.txt” file in “Training\Configuration” folder (see graphic below). 
 

 

�� Click on Open. 

The viewer will appear and the database will now be named, “Standard”. 
 
�� Click on OK. 

�� Use the horizontal scroll bar on the Viewer to inspect all the database fields that will be 
databased.  

We are going to analyze just a few reports to demonstrate how this last phase works. 
 



Part K – Phase 5 – Databasing and Printing Reports  ModFit LT Training 

(c) 2001 Verity Software House, Inc.  All rights reserved. K-3 Revision: 5/7/2001 

�� Click on the File menu, choose Open->Reports. 

�� Navigate to the “Training\Data\Aneuploid Files” folder (see graphic below). 

  

�� Multiple-select the aneuploid example files. 

�� Click on Open. 

�� Either choose “Report Batch Settings…” from the Edit menu or click on the Report Batch 
control’s “pencil” button. 
 

 

 
�� Select “Fit with current model” from the Analysis drop-down listbox. 

This selection is the important one.  You are telling the Report Batch control to fit the data with 
the current model when it loads in the report.  If the database system is active, all the results that 
match the database fields will be copied to the database and will appear as a new record in the 
Viewer. 
  
�� If you have a printer connected to your computer, enable the Print Report checkbox. 

�� Click on OK. 

�� Click on the Report Batch control’s Redo button. 

Notice that the first record is stored in the database.  Use the horizontal scrollbar of to examine all 
the stored database fields. 
 
�� Click on the Report Batch control’s Auto Advance button. 
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All the rest of the reports will be databased.  Keep in mind that you can multiple-select hundreds 
of reports for databasing and reporting. 
 
We’re going to delete the records just stored so that these tutorials can be re-used without 
changing the instructions. 
 
�� Click on the first column for Id “1”. 

�� Hold down the Shift key and click on the first column for Id “3” (see graphic below). 
 

 

 
�� Click on the Delete record button (-). 

�� Click Yes when asked whether you really want to delete the records. 

Let’s go back and turn off the databasing until we are ready to use it. 
 

�� Choose “Databases…” from the Edit menu. 

�� Click on the “Standard” database item to select it. 

�� Click on the Properties… button. 

�� Uncheck the Active and Viewer entries. 

�� Click on OK. 

Go take a look at the reports if you printed them.   
 
 
This is the end of section K: Phase 5 - Databasing and Printing Reports. 
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Part L – Proficiency Testing – 50+ minutes 
 
It’s now time to test your knowledge of performing cell cycle analysis on DNA histograms.  We have 
gathered some easy, not-so-easy and hard histograms for each DNA ploidy type.  In this section, we will 
be asking you to use the four-phase approach to analyze all these files.  After your final review, you will 
configure the system to store all your analysis results to a particular database.  That file will be imported 
into a specially designed Excel worksheet to evaluate your cell cycle analysis skills.  Take your time and 
try to remember the left-to-right technique in evaluating the reports in Phase 2.  Remember, use the rules 
in Appendix 1 to guide you through this process.  Good luck! 
 
 
Phase 1 – Perform Auto Analysis and generate report files. 
 
In a manner similar to the preceding sections, you will first load our DNA report template (if necessary), 
select all the proficiency files, properly configure the File Batch control and then process all the files 
using Auto Analysis. 
 

�� Click on the File menu and choose Open Report....  

�� Navigate to folder under “Data”, select the file, “DNAReportTemplate.mfl” then click on Open. 

�� Click on the File toolbar button (first tool button on left). 

�� Navigate to the “Proficiency Test Files” folder.   

�� Multiple-select all files (see figure below). 
 

  

 
�� Click the Open button. 

If the first file happens to have multiple “stacked” histograms, you may be prompted to enter the 
analysis parameter.  Choose “FL2-A” when prompted. 

 

As in earlier tutorials, we will configure the File Batch control to automatically analyze all the files and 
save the reports. 
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�� From the Edit menu, choose “File Batch Settings…” or select the File Batch control’s 
“pencil” button. 

�� From the drop-down Analysis listbox, select “Auto-analyze”.  

�� Check the Save Report option. 

�� Select the Save Report Path Folder… button and navigate to the desired report folder 
location.  For these files, we want to store the reports in the “Reports” folder under the 
“Proficiency Test Files” folder. 

�� Select Open to store this report pathway and to close the Choose a folder dialog box. 

�� Uncheck the Database and File prompt checkboxes.    
 
�� Select OK to close the Edit Properties for file processor dialog. 

 
Now we are ready to automatically process the files. 

 
�� In the File Batch control, click the Redo button to process the first file.  

�� Now select the File Batch control’s Auto-advance button to analyze the remaining files. 

After some processing, all the files will be Auto Analyzed and the reports saved. 
 

�� Click on the Save toolbar button to make sure the last report is saved. 

We now need to reset these File Batch properties in order that the program doesn’t prematurely start 
analyzing and saving reports if you start another tutorial section when your done. 

 
�� Choose either File Batch Settings from the Edit menu or click on the “pencil” edit button on 

the File Batch control. 

�� Select “No analysis” from the Analysis drop-down listbox. 

�� Uncheck the Save Report option. 

�� Check the File prompt checkbox. 

�� Click on OK. 

 
 
This completes Phase 1. 
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Phase 2 – Initial Review 
 
Use the left-to-right method and carefully review each report. 
 
Let’s load in all the reports. 
 

�� From the File menu, choose Open -> Report... 

�� Navigate (if necessary) to the “Proficiency Test Files\Reports” folder and multiple-select all of 
the reports. 

�� Select Open. 

�� Choose Report Batch Settings… from the Edit menu or click on the Report Batch control’s 
“pencil” icon. 

�� Choose ‘No analysis’ from the Analysis drop-down listbox.   

�� Choose “Re-save report” from the Save Report drop-down listbox. 

�� Leave the rest of the options in their default states (see graphic below). 
 

 

�� Click OK to save the settings and close the dialog. 

Review the first report.  Make any changes that are necessary.  Once you’re satisfied, click on the 
Report Batch control’s Next Batch Index button to go the next report.  Since you configured the Report 
Batch processor to save the reports, any changes you have made will be automatically saved when you 
move to the next report.  Continue in this manner until you have processed all the reports. 
 
 
End of Phase 2 
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Phase 3 – Automatic Linearity Factor Detection 
 
Let’s now find the optimum Linearity Factor all your stored reports. 
 

�� Click on the Report Batch control’s “pencil” button or choose Report Batch Settings from 
the Edit menu (see graph below).  

�� Select “Fit and do autolinearity” from the Analysis drop-down listbox. 

�� Leave the “Re-save” Save Report option selected. 

�� Select OK. 

�� Click on the “First Batch Item” button on the Report Batch control. 

�� When the first report is done processing, select the Auto Advance button on the Report 
Batch control to analyze the rest of the reports. 

�� Click on the Save toolbar button to make sure the last report is saved.  

End of Phase 3. 
   
Phase 4 –Final Review 
 
Now for your final review…   
 

�� Click on the Report Batch control’s “pencil” button or choose Report Batch Settings from 
the Edit menu 

�� Select “No analysis” in the Analysis drop-down listbox. 

�� Select “Don’t re-save report” from the Save Report drop-down listbox. 

�� Click on OK. 

�� Select the “First Batch Item” button on the Report Batch control. 

�� Inspect all the reports by using the Report Batch control’s Next Batch Item button. 

If you need to make changes to the reports at this point, you need to completely reanalyze the 
file, including the AutoLinearity analysis.  Don’t forget to save the report with the Save button 
when you are done.  Do not use Auto Analysis since it will automatically load a new model and 
reset all your changes.   
 
To perform the AutoLinearity analysis on a single report, use the following procedure. 
 
Choose “Quick Model Editor…” from the Edit menu. 
Check the AutoLinearity checkbox. 
Click on OK. 
Click on the Fit toolbar button. 
 

End of Phase 4. 
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Phase 5 – Databasing and Printing Reports 
 
Now that all the reports have been reviewed, we will database the results and compare them with the  
“Reference” analyses.  It’s very important that you have exactly the right number of reports.  For this 
Proficiency Exam, you should have 29 reports. 
 

�� From the Edit menu, choose “Databases…” 

�� Select “Standard” in the listbox (see graphic below). 
 

 

 
�� Click on Properties…. 

 
 
 
�� Check and uncheck the options as shown above. 

The Active checkbox will activate the database for the current modeling session.  We don’t want 
the database system to prompt us to save a record and the Viewer allows us to inspect the 
records of the database as they are created.  
 
�� Click on the Choose button (see graphic above). 

�� Navigate to the “Standard.txt” file in “Training\Data\Proficiency Test Files\Reports” folder (see 
graphic below). 
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�� Click on Open. 

The Viewer will appear and the database will be named, “Standard”. 
 
�� Click on OK to close the Edit Properties for Standard dialog. 

�� Click on Ok to close the Edit All Databases dialog. 

If there are records in the Viewer, delete them all using the same procedure as discussed in the 
previous tutorial. 
 
�� Either choose “Report Batch Settings…” from the Edit menu or click on the Report Batch 

control’s “pencil” button. 
 

 

 
�� Select “Fit with current model” from the Analysis drop-down listbox. 

�� Click on OK. 

�� Click on the Report Batch control’s Go to the first batch item button. 

�� Click on the Report Batch control’s Auto Advance button. 
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When you are done, your Viewer should look like the graphic below: 
 

 
 

As mentioned earlier, it is very important that you have exactly 29 records in this database (see graphic 
above, last line). 
 
We are now done databasing and should turn the Database system off. 
 

�� Click on “Databases...” under the Edit menu. 

�� Select the “Standard” database item. 

�� Click on the Properties... button. 

�� Uncheck the Active and Viewer checkboxes. 

�� Click on OK. 

�� Click on OK again. 

Importing into Excel 
 
We are ready to import this database into our specially designed Excel 2000 Workbook.  
 

�� With Windows Explorer (normally found in “Start\Programs\Accessories”), navigate to 
“Training\Data\Proficiency Test Files\ExamAnalysis” folder. 

If you are running these tutorials from the Macintosh and you have Excel 2000 for the Mac, use 
Finder to navigate to the Excel workbook file. 
 
�� Double-click on the “ProficiencyTestResults.xls” file. 

�� Click on the “Your Data” tab at the bottom of the workbook. 

�� If there are any cells containing data, select and delete them. 
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�� Click on Open... under Excel’s File menu. 

�� Choose “Text Files...” from the File Type drop-down listbox. 

�� In the Look in tree-list control, navigate to “Proficiency Test Files\Reports”. 

�� Select “Standard.txt” and click on Open. 

�� When the Text Import Wizard appears, click on the Finish button. 

�� Select all the rows and columns in the Standard.txt worksheet. 

For Windows users this operation is conveniently done by pressing the Ctrl – Shift – End keys all 
at the same time. 
 
�� Select Copy from the Edit menu. 

�� Click on the title bar of the Proficiency Test Results workbook to activate it. 

�� Click on the upper-left cell to set the focus. 

�� Select Paste from the Edit menu. 

If all went according to plan, you should have the first 30 rows filled with data. 
 
�� Go back to the “Standard.txt” workbook and close it. 

�� If prompted to save contents of the clipboard, choose the No button. 

Once you are done importing data into Excel from ModFit LT, it is a good idea to close this 
workbook.  If you leave it open in Excel, then ModFit LT will not be able to work with it, which can 
eventually result in an error. 
 
�� Click on the “Diploid Analyses” worksheet tab. 

  
 
The table in the upper-left of the worksheet should receive most of your attention.  The first 
column shows the names of the DNA diploid files.  The next two columns are the comparison 
between the “Reference” and “Your Data” S-phases.  If there is a difference of greater than 0.1%, 
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the cell will be shaded in red.  If any of these cells are red, review the Part G – DNA Diploid files 
tutorial and re-examine your relevant reports.  If you still can’t figure out why they are different, 
look at the corresponding “Reference” report (ProficiencyTestFiles\ReferenceReports).  Try to 
only review the “Reference” reports as a last resort. 
 
Underneath this table is another table that calculates the average absolute difference and the 
correlation coefficient between the “Reference” and “Your Data” S-phases.  If these values are 
shaded in red then the mistakes made were probably more than just minor mistakes and you 
need to eventually redo this proficiency exam. 
 
The last table, “Ploidy Reclassification Analysis”, shows a breakdown of the analyzed files.  In the 
case of the DNA diploid files, the first column should show 100% of the files categorized as DNA 
diploids.  If you don’t have the correct DNA ploidy for the histogram, then the S-phase will not be 
accurate or reproducible.  This table may provide clues as to what type of DNA ploidy you are 
confusing with the DNA diploids.  For example, if a few files were misclassified as DNA 
tetraploids, you should go back to the Part H - DNA Tetraploid files tutorial and review it 
completely. 
 
The graph on the right plots the “Reference” vs. “Your Data” S-phases.  This graph provides an 
overall qualitative comparison between these two sets of S-phases. 
 
Once you have finished the “Diploid Analyses”, click on the “Tetraploid Analyses” worksheet tab.  
The format of this worksheet is the same as we have just discussed except that it analyzes your 
proficiency with DNA tetraploid histograms. 
 
Continue this analysis with “Aneuploid Analyses” and “Multiploid Analyses”. 
 

We at Verity hope you have found these DNA histogram analysis tutorials useful.  We are convinced that 
if users are adequately trained, they can efficiently analyze DNA histograms and obtain consistent and 
relevant DNA Ploidy and S-phase estimates.  
 
 
This is the end of section L: Proficiency Testing. 
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Part M- Advanced Modeling Techniques:  
 
Occasionally, the standard set of models provided with ModFit LT cannot handle a particular analysis 
problem.  In these situations, it is necessary to be able to edit some low level aspects of the DNA 
histogram model.  In this section, we will introduce how to do these kinds of edits with a histogram that 
cannot be modeled accurately with the standard models.  
 
 Phase 1 – Perform Auto Analysis and generate report files. 
 
In a manner similar to the preceding sections, we will first load our DNA report template (if necessary), 
select the problem file and then process the file using Auto Analysis. 
 

�� Click on the File menu and choose Open Report....  

�� Navigate to the folder under “Data”, select the file “DNAReportTemplate.mfl” and click on 
Open. 

�� Click on the File toolbar button (first tool button on left). 

�� Navigate to the “WithStds” folder (see figure below).   

�� Select file “BCS182" (see figure below). 
 

 

�� Click the Open button. 

�� Select “FL2-A” as the analysis parameter. 

�� Click OK to close the Choose Histogram dialog box. 

Since we only chose one file, the File Batch processor is not loaded and will not be used. 
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�� Click on the Auto button to initiate Auto Analysis. 

�� Click on the File menu and select the “Save As…” menu 

 

The steps below assume that there currently is no Reports folder under the WithStds folder.  If 
there is a folder there already, you don’t need to do the next three steps. 
 
�� Navigate to the “WithStds” folder and click on the New folder button. 

 

�� Type “Reports” into the edit line for the name of the new folder. 
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�� Click on OK. 

�� Select the new “Reports” folder, then type the file name “BCS205.MFL into the “Save as:” edit 
box. 

 

�� Click on Save.  

�� The Auto Analysis report for file BSC182.fcs has now been save to the folder we just 
created. 

This process of manually saving a report file using the Save As option sets the location where 
subsequent reports will be saved. 
 

 
This completes Phase 1.  
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Phase 2 - Initial Review 
 
Since we are working with a single file, we do not have to reload the report to do the Phase 2 review. 
 

�� Let’s examine the report. 

 
 
1,2.  Notice that the second standard, trout erythrocytes, is not visible and that the DNA diploid 
and aneuploid G1 populations are trying to fit the same area.  Whenever you see two model 
components of similar shape trying to fit data in the same area of the histogram, a mental red flag 
should appear.  As we have discussed before, superimposed model components cannot be 
expected to perform reliably in this situation.  The rule II.B.1.a.1 states, “If two model components 
are of similar shape and are highly overlapped (>75%), it may be necessary to add additional 
constraints to the model or, in the worse case, disable the model component of lesser 
importance.”  As you will see in a moment, we are not only going to disable a model component 
of lesser importance but we will also add a model constraint to make it work the way we want. 
 
3,?.  Auto Analysis has classified the peak near channel 85 as the G1 of a third cycle.  Take a 
careful look at the Y-zoomed graph below the histogram and decide whether you agree with this 
decision or not.  Try to back your decision up with one of the analysis rules.  Which is the 
appropriate rule to use?   
 

1

2

3

?
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��The second standard must be turned off and the first G1 modeled as a DNA 
hypodiploid.  Because the “near diploid” rules also apply, the S-phase of the lesser 
significant population (diploid population) needs to be turned off and the G2 
populations made dependent on their corresponding G1 populations.  
  

��Since the 8C peak is not greater than the 6C peak, we have no evidence of a third cell 
cycle and we should therefore change the model accordingly.  
 

If you missed the second observation and conclusion, review the DNA tetraploid tutorial. 
 

Let’s start by selecting a better model that solves some of the identified problems associated with 
this analysis. 
 
�� Click on the Mod toolbar button. 

 
 

�� In the Edit Properties for Manual Analysis dialog box, change the number of standards to 
“1” (see graphic below). 

�� From the Model template drop-down list box, choose “Hyp Dip” (see graphic below). 

�� Select “Use current range positions” from the Range positions drop-down list box (see 
graphic below).   

If you leave this option set to “Compute range positions”, the program will move all of the ranges.  
Since Auto Analysis calculated most of the populations correctly, it is best to use the “Use 
current range positions” option in order to minimize the number of ranges to move or resize.   
  

  

 
 

�� Click on the “Cycle2” object under Manual Analysis (left panel). 
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�� Select “Indistinct peak” from the G2M dropdown listbox (see figure above). 

When “Indistinct peak” is chosen, the model calculates the G2M position from the G1 position by 
multiplying its mean position by the current linearity factor.  An “Indistinct peak” option adds 
rigidity and stability to the affected G2M model component. 
 
�� The S-phase option should be unchecked. 

�� Click on OK. 

�� You will need to adjust the “Dip G1”, “Dip G2”, “An1 G1” and “An1 G2” ranges (see graphic 
below).   

 

�� Click on the Fit toolbar button. 
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Note that your analysis may not be the same as the one shown below. In a moment will make the 
system a lot more stable.   
 

 
 
As we mentioned earlier, when two model components overlap heavily, it may be necessary to 
add more constraints to the model to give the fit some stability.  In this case, the CV of the DNA 
hypodiploid population is much larger than the DNA diploid population.  In order to make the 
model work as we want, we need to force the standard deviations of these two model 
components to be the same. 
 
This case is very rare but it does serve as an excellent demonstration of how these DNA models 
can fail when populations overlap too much. 
 
 

��Make standard deviation of the diploid population dependent on the standard deviation 
of the aneuploid by a factor of 1. 
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�� Choose “Full Model Editor…” from the Edit menu (see graphic below). 

 

�� Double click on the "Components" object in the Edit 2SA1n_DnD_HSD dialog box.. 

 

This dialog box lists three groups of model objects, “Components”, “Ranges” and “Equations”.  
The “Component” group contains the individual objects and details that make up the 
mathematical model (rectangle, gaussian, debris, and aggregate components).  The “Range” 
group contains the list of ranges and how they are associated with the components.  The 
“Equations” group contains the equations used to calculate the results shown on the report. 
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�� Double Click on the "Dip G1" (see graphic below) 

. 

The Edit Properties for Dip G1 dialog box will be displayed (see graphic below).  This dialog allows you 
to edit all of the attributes for the “Dip G1” model component.   
 

 

�� Click on the "SD" object in the left window of the Edit Properties for Dip G1 dialog box (see 
below). 

 

The panel on the right side (see figure below) shows the details associated with the calculation of the 
“Dip G1” standard deviation.  Note that the "Dependency" listbox  is set as "Floating" which means that 
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the program is free to adjust this value to optimize the fit.  When the "Dependency" detail is "Floating", 
most of the other values in the dialog are not used by the program.   

 

�� Select "Dependent" in the "Dependency" dropdown list (see graphic below). 

 

�� Change the "Controlling detail" component from "Dip G1" to "An1 G1" (see graphic below) 

�� Check that the other values are set as they are in the graphic below. 

 

 
By setting these properties of the “Dip G1 SD” up in this manner, we are telling the model to 
make the DNA diploid standard deviation dependent on the DNA hypodiploid’s standard deviation 
by a factor of one.  The end result will be that the widths of these two components will be the 
same.   
 
Take a moment to appreciate the flexibility implicit in this design.  You can identify relationships 
between any model components.  Specialized models can be constructed and saved for future 
use. 
 
For typical DNA analysis, don’t overuse this powerful ability to control the models.  Since these 
low level edits cannot be standardized, they should only be used in the few cases where the 
models just will not work properly.  

 
�� Click on OK for the Edit Properties for Dip G1 dialog box. 

�� Click on OK for Edit Components dialog box. 

�� Click on OK for Edit 2DA1n_DnD_HSD dialog box. 
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�� Click on the Fit button. 

�� The graph below shows the new analysis.  This analysis should now show a reasonable fit for 
both the DNA hypodiploid G1 and G2 populations (yellow elements) and the DNA diploid G1 
and G2 populations (red elements). 

 

�� Click on the Save button 

 
 
This concludes Phase 2.   

 



Part M – Advanced Modeling Techniques  ModFit LT Training 

(c) 2001 Verity Software House, Inc.  All rights reserved. M-12 Revision: 5/7/2001 

Phase 3 – Automatic Linearity Factor Detection 
 
Let’s now find the optimum Linearity Factor. 
 

�� Select "Quick Model Editor" from the Edit menu.  

 

�� Enable the AutoLinearity option (see graphic below). 

 

�� Select OK 
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�� Click on the Fit button. 

�� Click on the Save button. 

 

  

End of Phase 3. 
   
Phase 4 –Final Review 
 
Now for our final review…   
 

�� Inspect the first report to make sure the new Linearity Factor did not negatively affect the fit.  

The DNA hypodiploid model fit should look reasonable.  Notice that the DNA diploid population 
has zero percent S-phase. 
 
You might now want to print this report and or add the analysis results to a database.   

  
 

This is the end section M - Advanced Modeling Techniques Tutorial. 
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Note: This document may change over time as additional data is obtained 
from participating laboratories.
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Rules for Obtaining High Quality DNA Histograms and Optimizing Correlation 
of S-phase Estimates Between Operators 

 

I. Acquisition Rules 

A. Parameter 
The DNA fluorescence parameter should be either a linear integral or area type of signal.  It is 
important to maintain a consistent gain setting. See further under point 1.F 
 

B. Linearity 
The linearity of the DNA fluorescence amplifier should be tested.  Non-linear amplifiers should not 
be used for DNA analysis. 
 

C. Discriminator 
Events should be discriminated on the DNA fluorescence parameter only (e.g. red fluorescence 
for Propidium Iodide).  The discriminator level should be as low as possible without creating a 
debris peak that is greater than the highest G0G1 peak. 

D. Gating 
Gating should not be performed during acquisition.  Gating is only recommended for 
multiparameter DNA histograms such as cytokeratin vs DNA or BrdUrd vs DNA.  Gating on light 
scatter is not recommended due to the heterogeneity of the distribution.  Signal processing gating, 
signal peak height vs signal peak area, to eliminate aggregates is only recommended if the 
aggregates are clearly and completely separated from singlet particles which is usually only true 
for experimental tissue culture cell lines. 

E. Number of Events and Resolution 
Simulation studies indicate that for accurate S-phase estimates, there should be an average of 
approximately 100 events per channel between the lowest G1 and highest G2 of the histogram 
when the resolution is 256 channels. If a histogram has its diploid G0G1 on channel 50 and the 
last G2 of an aneuploid population is at 200, there should be at least 15,000  events between 
channels 50 and 200. 

F. Location of diploid G0G1 
The position of the diploid G0G1 peak should always be placed in about the same channel.  For 
256 channel histograms the recommended location is channel 50.  For 1024 channel histograms 
(not normally recommended because it requires collection of 400% more events for same 
histogram at 256 channels), the location is channel 200.   
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G. Changing Gains 

1. Normally adjust the gain to center the DNA diploid peak on a particular 
channel (e.g. 50). 

2. When a hyper-tetraploid population is observed during acquisition, it is 
desirable to reduce the gain so that its G2M and some channels consisting of 
only background are on scale. 

3. Note, after adjusting gain, acquisition must be restarted.  Gain should be 
reset to the normal location when running the next sample. 

G. Time or Chronology Parameter 
If the instrument supports either time or chronology it is highly recommended to view a time vs. 
DNA parameter to detect any peak shifts during acquisition. 

II. Analysis Rules 

A. General Procedure 

1. Analyze all histograms in automatic analysis mode. 

a) For best results, try to use settings for the program’s configuration, 
peak finding characteristics and automatic analysis properties that 
results in most histograms being analyzed accurately.  

2. Evaluate and review each stored analysis report and re-analyze if the model 
used is incorrect for the data. 

3. If available, run automatic linearity adjustment on all reports. 

4. Final review. 

B. Reviewing Process 

1. Model Selection Check 
The most important step in analyzing DNA histograms in a consistent manner is checking the 
correct ploidy model for a particular DNA histogram.  In some cases this process may require 
several analyses to achieve the correct and optimal fit, i.e. the RCS value should be as low as 
possible (< 3.0).  Use the rules below to help guide you through this process. 
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a) General Considerations 

(1) If two model components are of similar shape and are 
highly overlapped (>75%), it may be necessary to add 
additional constraints to the model or, in the worse case, 
disable the model component of lesser importance. 

(2) If a G2M peak is clearly visible and well-defined, allow its 
mean to be fitted (float) unless there is another overlapping 
population. 

(a) If a floating G2M yields a G2/G1 ratio that is outside the expected 
linearity range (e.g. <1.8 or >2.2), make the G2M’s mean and standard 
deviation dependent on G1 by the appropriate linearity factor (e.g. 1.95). 

(3) Always model S-phase as a single, broadened rectangle. 

(4) When choosing between two very similar models, select 
the one that gives consistent results with slightly different 
range settings. 

(a) An example of this rule might be when trying to use an aneuploid 
model with a near-tetraploid type of histogram.  If the aneuploid model 
only works with very specific range settings, choose the tetraploid model 
instead. 

b) Tetraploid Model Selection 

(1) Select a tetraploid model if the DI is close to the expected 
diploid G2/G1 ratio 

(a) Use +/- 0.15 ratio units as a guide but note that if the diploid G2 is 
not modeled properly, a tetraploid model may be necessary even though 
it falls outside of the above range. 

(2) There is another peak at (8C) that cannot be explained as 
an aggregate. 

(a) Consider the 8C peak to be an aggregate if it is less than the 6C 
peak. 

(3) Choose a tetraploid model over an aneuploid model if the 
diploid G2M overlaps too significantly with an aneuploid G1. 
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(a) The diploid G2M will generally only model properly if there is a 
clearly distinguished peak at its expected location. 

(b) Inappropriate fits of the diploid G2M are usually associated with a 
zero or very high calculated percentage or a location that results in a 
G2/G1 ratio outside the expected range. 

c) Aneuploid Model Selection 

(1) Only choose this model if the potential aneuploid’s G0G1 
cannot be explained as an aggregate or some other part of 
another cycle (e.g. G2M). 

(2) and there are adequate channels to model the entire 
cycle. 

d) Near diploid Model Selection 

(1) Choose the near diploid model if the two G0G1 peaks can 
be clearly distinguished and the resulting fit seems 
appropriate. 

(2) If the DI is between 0.7-1.0 or 1.0-1.3 disable the diploid S-
phase and make both G2’s dependent. 

(3) For very near-diploids, it may be necessary to force the 
standard deviations of the two G0G1 model components to 
be equal to yield an appropriate fit. 

e) Hypo-diploid Model Selection 

(1) Only select a hypo-diploid model when there are 
standards or normal controls that accurately determine the 
expected diploid G0G1 position. 

(2) If the hypo-diploid G0G1 overlaps one of the standards, 
disable the standard model component and re-model. 

(3) Near-diploid rules apply 

2. Range Positions Check 
The most common reason for uncorrelated results between two fits using the same model is 
inattention to range positions.  Do not change a range setting unless it is absolutely necessary to 
do so. 
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a) Debris Range 

(1) The beginning of the debris range should correspond to 
the channel with the highest debris counts (see Figure 1, 
Range: Debris for examples of correct and incorrect 
placements).   

b) Peak Ranges 

(1) Center range about the peak and make sure estimates 
appropriately fit the data (see Figure 1, Range: Peak G0G1 
and Range: Peak G2M examples of correct and incorrect 
placements). 

(2) Exceptions to centering the range are for near-diploid and 
near-tetraploid G0G1 peaks.  These ranges need to be 
displaced to yield reasonable estimates for the underlying 
peaks. 
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III. Figures (400x300 gifs) 
 
Figure 1 
 

Rule 
Description 

Correct Incorrect #1 

Range: 
Debris 

  
Range: 
AN1 G1 

  
Range: 
AN1 G2 

 
 


